CVE-2018-11385 Symfony Session Fixation Vulnerability
An attacker can impersonate a victim in Symfony applications using the Guard login feature if the session ID is known, leading to account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-11385?
CVE-2018-11385 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. A session fixation vulnerability within the "Guard" login feature may allow an attacker to impersonate a victim towards the web application if the session id value was previously known to the attacker.
Weakness: CWE-384
Which versions are affected by CVE-2018-11385?
30 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.7.0 | 2.7.48 |
symfony/security Packagist | From 2.7.0 | 2.7.48 |
symfony/security Packagist | From 2.8.0 | 2.8.41 |
symfony/security Packagist | From 2.8.0 | 2.8.41 |
symfony/security Packagist | From 3.0.0 | 3.3.17 |
symfony/security Packagist | From 3.0.0 | 3.3.17 |
24 more packages
symfony/security Packagist | From 3.4.0 | 3.4.11 |
symfony/security Packagist | From 3.4.0 | 3.4.11 |
symfony/security Packagist | From 4.0.0 | 4.0.11 |
symfony/security Packagist | From 4.0.0 | 4.0.11 |
symfony/security-http Packagist | From 2.7.0 | 2.7.48 |
symfony/security-http Packagist | From 2.7.0 | 2.7.48 |
symfony/security-http Packagist | From 2.8.0 | 2.8.41 |
symfony/security-http Packagist | From 2.8.0 | 2.8.41 |
symfony/security-http Packagist | From 3.0.0 | 3.3.17 |
symfony/security-http Packagist | From 3.0.0 | 3.3.17 |
symfony/security-http Packagist | From 3.4.0 | 3.4.11 |
symfony/security-http Packagist | From 3.4.0 | 3.4.11 |
symfony/security-http Packagist | From 4.0.0 | 4.0.11 |
symfony/security-http Packagist | From 4.0.0 | 4.0.11 |
symfony/symfony Packagist | From 2.7.0 | 2.7.48 |
symfony/symfony Packagist | From 2.7.0 | 2.7.48 |
symfony/symfony Packagist | From 2.8.0 | 2.8.41 |
symfony/symfony Packagist | From 2.8.0 | 2.8.41 |
symfony/symfony Packagist | From 3.0.0 | 3.3.17 |
symfony/symfony Packagist | From 3.0.0 | 3.3.17 |
symfony/symfony Packagist | From 3.4.0 | 3.4.11 |
symfony/symfony Packagist | From 3.4.0 | 3.4.11 |
symfony/symfony Packagist | From 4.0.0 | 4.0.11 |
symfony/symfony Packagist | From 4.0.0 | 4.0.11 |
Products include Debian Debian Linux, Fedoraproject Fedora, Sensiolabs Symfony.
How do I fix CVE-2018-11385?
Upgrade symfony/security to a fixed version for your release line: 2.7.48, 2.8.41, 3.3.17 or 3.4.11.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2018-11385 being exploited?
There is no known exploitation of CVE-2018-11385 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-11385, GHSA-g4rg-rw65-8hfg, UBUNTU-CVE-2018-11385.