# CVE-2018-11385: Symfony Session Fixation Vulnerability

> An attacker can impersonate a victim in Symfony applications using the Guard login feature if the session ID is known, leading to account takeover.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-11385, GHSA-g4rg-rw65-8hfg, UBUNTU-CVE-2018-11385

## What is CVE-2018-11385?

CVE-2018-11385 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the Security component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. A session fixation vulnerability within the "Guard" login feature may allow an attacker to impersonate a victim towards the web application if the session id value was previously known to the attacker.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2018-11385?

30 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.48 |
| `symfony/security` | Packagist | From 2.7.0 | 2.7.48 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.41 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.41 |
| `symfony/security` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security` | Packagist | From 3.4.0 | 3.4.11 |
| `symfony/security` | Packagist | From 3.4.0 | 3.4.11 |
| `symfony/security` | Packagist | From 4.0.0 | 4.0.11 |
| `symfony/security` | Packagist | From 4.0.0 | 4.0.11 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.48 |
| `symfony/security-http` | Packagist | From 2.7.0 | 2.7.48 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.41 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.41 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security-http` | Packagist | From 3.4.0 | 3.4.11 |
| `symfony/security-http` | Packagist | From 3.4.0 | 3.4.11 |
| `symfony/security-http` | Packagist | From 4.0.0 | 4.0.11 |
| `symfony/security-http` | Packagist | From 4.0.0 | 4.0.11 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.48 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.48 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.41 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.41 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/symfony` | Packagist | From 3.4.0 | 3.4.11 |
| `symfony/symfony` | Packagist | From 3.4.0 | 3.4.11 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.11 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.11 |

Products: Debian Debian Linux, Fedoraproject Fedora, Sensiolabs Symfony.

## How do I fix CVE-2018-11385?

Upgrade symfony/security to a fixed version for your release line: 2.7.48, 2.8.41, 3.3.17 or 3.4.11.

## Is CVE-2018-11385 being exploited?

There is no known exploitation of CVE-2018-11385 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11385 and fix it if it is affected.

What it is: CVE-2018-11385 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11385 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.48
- symfony/security (Packagist): affected from 2.7.0; fixed in 2.7.48
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.41
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.41
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.3.17
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.3.17
- symfony/security (Packagist): affected from 3.4.0; fixed in 3.4.11
- symfony/security (Packagist): affected from 3.4.0; fixed in 3.4.11
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.0.11
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.0.11
- symfony/security-http (Packagist): affected from 2.7.0; fixed in 2.7.48
- symfony/security-http (Packagist): affected from 2.7.0; fixed in 2.7.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11385/ (Markdown: https://insights.sbomify.com/CVE-2018-11385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11385
- OSV: https://osv.dev/vulnerability/CVE-2018-11385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11385/
Summaries are generated and may contain mistakes; the official description above is the record.
