CVE-2018-11386 Symfony DoS
Attackers can cause denial of service in Symfony applications using PDOSessionHandler under specific configurations with crafted payloads.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-11386?
CVE-2018-11386 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in the HttpFoundation component in Symfony 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11. The PDOSessionHandler class allows storing sessions on a PDO connection. Under some configurations and with a well-crafted payload, it was possible to do a denial of service on a Symfony application without too much resources.
Weakness: CWE-613
Which versions are affected by CVE-2018-11386?
20 open source packages ship an affected version, including symfony/http-foundation and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/http-foundation Packagist | From 2.7.0 | 2.7.48 |
symfony/http-foundation Packagist | From 2.7.0 | 2.7.48 |
symfony/http-foundation Packagist | From 2.8.0 | 2.8.41 |
symfony/http-foundation Packagist | From 2.8.0 | 2.8.41 |
symfony/http-foundation Packagist | From 3.3.0 | 3.3.17 |
symfony/http-foundation Packagist | From 3.3.0 | 3.3.17 |
14 more packages
symfony/http-foundation Packagist | From 3.4.0 | 3.4.11 |
symfony/http-foundation Packagist | From 3.4.0 | 3.4.11 |
symfony/http-foundation Packagist | From 4.0.0 | 4.0.11 |
symfony/http-foundation Packagist | From 4.0.0 | 4.0.11 |
symfony/symfony Packagist | From 2.7.0 | 2.7.48 |
symfony/symfony Packagist | From 2.7.0 | 2.7.48 |
symfony/symfony Packagist | From 2.8.0 | 2.8.41 |
symfony/symfony Packagist | From 2.8.0 | 2.8.41 |
symfony/symfony Packagist | From 3.3.0 | 3.3.17 |
symfony/symfony Packagist | From 3.3.0 | 3.3.17 |
symfony/symfony Packagist | From 3.4.0 | 3.4.11 |
symfony/symfony Packagist | From 3.4.0 | 3.4.11 |
symfony/symfony Packagist | From 4.0.0 | 4.0.11 |
symfony/symfony Packagist | From 4.0.0 | 4.0.11 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2018-11386?
Upgrade symfony/http-foundation to a fixed version for your release line: 2.7.48, 2.8.41, 3.3.17 or 3.4.11.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2018-11386 being exploited?
There is no known exploitation of CVE-2018-11386 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-11386, GHSA-r2rq-3h56-fqm4, UBUNTU-CVE-2018-11386.