# CVE-2018-11407: Symfony Authentication Bypass

> Remote attackers can bypass authentication in Symfony's Ldap component by logging in with a null password and valid username.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-11407, GHSA-35c5-28pg-2qg4, UBUNTU-CVE-2018-11407, USN-4836-1

## What is CVE-2018-11407?

CVE-2018-11407 is a critical authentication bypass vulnerability in Sensiolabs Symfony, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind.  NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-11407?

24 open source packages ship an affected version, including symfony/security, symfony/security-core and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.37 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.37 |
| `symfony/security` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security` | Packagist | From 3.4.0 | 3.4.7 |
| `symfony/security` | Packagist | From 3.4.0 | 3.4.7 |
| `symfony/security` | Packagist | From 4.0.0 | 4.0.7 |
| `symfony/security` | Packagist | From 4.0.0 | 4.0.7 |
| `symfony/security-core` | Packagist | From 2.8.0 | 2.8.37 |
| `symfony/security-core` | Packagist | From 2.8.0 | 2.8.37 |
| `symfony/security-core` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security-core` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/security-core` | Packagist | From 3.4.0 | 3.4.7 |
| `symfony/security-core` | Packagist | From 3.4.0 | 3.4.7 |
| `symfony/security-core` | Packagist | From 4.0.0 | 4.0.7 |
| `symfony/security-core` | Packagist | From 4.0.0 | 4.0.7 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.37 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.37 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.3.17 |
| `symfony/symfony` | Packagist | From 3.4.0 | 3.4.7 |
| `symfony/symfony` | Packagist | From 3.4.0 | 3.4.7 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.7 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.7 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2018-11407?

Upgrade symfony/security to a fixed version for your release line: 2.8.37, 3.3.17, 3.4.7 or 4.0.7.

## Is CVE-2018-11407 being exploited?

There is no known exploitation of CVE-2018-11407 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2026-45063](https://insights.sbomify.com/CVE-2026-45063/): Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11407 and fix it if it is affected.

What it is: CVE-2018-11407 is a critical authentication bypass vulnerability in Sensiolabs Symfony, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11407 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.37
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.37
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.3.17
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.3.17
- symfony/security (Packagist): affected from 3.4.0; fixed in 3.4.7
- symfony/security (Packagist): affected from 3.4.0; fixed in 3.4.7
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.0.7
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.0.7
- symfony/security-core (Packagist): affected from 2.8.0; fixed in 2.8.37
- symfony/security-core (Packagist): affected from 2.8.0; fixed in 2.8.37
- symfony/security-core (Packagist): affected from 3.0.0; fixed in 3.3.17
- symfony/security-core (Packagist): affected from 3.0.0; fixed in 3.3.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11407/ (Markdown: https://insights.sbomify.com/CVE-2018-11407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11407
- OSV: https://osv.dev/vulnerability/CVE-2018-11407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11407/
Summaries are generated and may contain mistakes; the official description above is the record.
