CVE-2018-11408 Symfony Open Redirect
An open redirect vulnerability in Symfony's security handlers allows attackers to redirect users to malicious sites when specific container configurations are used.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-11408?
CVE-2018-11408 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The security handlers in the Security component in Symfony in 2.7.x before 2.7.48, 2.8.x before 2.8.41, 3.3.x before 3.3.17, 3.4.x before 3.4.11, and 4.0.x before 4.0.11 have an Open redirect vulnerability when security.http_utils is inlined by a container. NOTE: this issue exists because of an incomplete fix for CVE-2017-16652.
Weakness: CWE-601
Which versions are affected by CVE-2018-11408?
20 open source packages ship an affected version, including symfony/security-bundle and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security-bundle Packagist | From 2.7.0 | 2.7.48 |
symfony/security-bundle Packagist | From 2.7.0 | 2.7.48 |
symfony/security-bundle Packagist | From 2.8.0 | 2.8.41 |
symfony/security-bundle Packagist | From 2.8.0 | 2.8.41 |
symfony/security-bundle Packagist | From 3.3.0 | 3.3.17 |
symfony/security-bundle Packagist | From 3.3.0 | 3.3.17 |
14 more packages
symfony/security-bundle Packagist | From 3.4.0 | 3.4.11 |
symfony/security-bundle Packagist | From 3.4.0 | 3.4.11 |
symfony/security-bundle Packagist | From 4.0.0 | 4.0.11 |
symfony/security-bundle Packagist | From 4.0.0 | 4.0.11 |
symfony/symfony Packagist | From 2.7.0 | 2.7.48 |
symfony/symfony Packagist | From 2.7.0 | 2.7.48 |
symfony/symfony Packagist | From 2.8.0 | 2.8.41 |
symfony/symfony Packagist | From 2.8.0 | 2.8.41 |
symfony/symfony Packagist | From 3.3.0 | 3.3.17 |
symfony/symfony Packagist | From 3.3.0 | 3.3.17 |
symfony/symfony Packagist | From 3.4.0 | 3.4.11 |
symfony/symfony Packagist | From 3.4.0 | 3.4.11 |
symfony/symfony Packagist | From 4.0.0 | 4.0.11 |
symfony/symfony Packagist | From 4.0.0 | 4.0.11 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2018-11408?
Upgrade symfony/security-bundle to a fixed version for your release line: 2.7.48, 2.8.41, 3.3.17 or 3.4.11.
Is CVE-2018-11408 being exploited?
There is no known exploitation of CVE-2018-11408 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-11408, GHSA-7hwc-2cq4-6x2w, UBUNTU-CVE-2018-11408.