# CVE-2018-11537: Auth0 angular-jwt misinterprets allowlist as regex

> Attackers can bypass domain whitelist filters in the angular-jwt library by exploiting regex interpretation of whitelist entries.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vm2p-f5j4-mj6g

## What is CVE-2018-11537?

CVE-2018-11537 is a medium-severity vulnerability in n/a, published on 19 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Auth0 angular-jwt before 0.1.10 treats whiteListedDomains entries as regular expressions, which allows remote attackers with knowledge of the jwtInterceptorProvider.whiteListedDomains setting to bypass the domain whitelist filter via a crafted domain.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-11537?

2 open source packages ship an affected version, including angular-jwt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `angular-jwt` | npm | All versions | 0.1.10 |
| `angular-jwt` | npm | All versions | 0.1.10 |

Products: Auth0 Angular-Jwt.

## How do I fix CVE-2018-11537?

Upgrade angular-jwt to 0.1.10 or later.

## Is CVE-2018-11537 being exploited?

There is no known exploitation of CVE-2018-11537 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11537 and fix it if it is affected.

What it is: CVE-2018-11537 is a medium-severity vulnerability in n/a, published on 19 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11537 in the wild and no public exploit code.

Affected packages and fixed versions:
- angular-jwt (npm): affected all versions; fixed in 0.1.10
- angular-jwt (npm): affected all versions; fixed in 0.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11537/ (Markdown: https://insights.sbomify.com/CVE-2018-11537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11537
- OSV: https://osv.dev/vulnerability/CVE-2018-11537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11537/
Summaries are generated and may contain mistakes; the official description above is the record.
