CVE-2018-11615 Mosca REDoS Vulnerability

High 7.5 Published Updated

Remote attackers can crash the MQTT broker by sending crafted regular expressions in topic processing, causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-11615?

CVE-2018-11615 is a high-severity denial of service vulnerability in npm mosca, published on 30 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

This vulnerability allows remote attackers to deny service on vulnerable installations of npm mosca 2.8.1. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of topics. A crafted regular expression can cause the broker to crash. An attacker can leverage this vulnerability to deny access to the target system. Was ZDI-CAN-6306.

Weakness: CWE-185, CWE-20

Which versions are affected by CVE-2018-11615?

2 open source packages ship an affected version, including mosca. It affects 1 product.

PackageAffectedFixed in
mosca npmAll versions2.8.2
mosca npmAll versions2.8.2

Products include Mosca Project Mosca.

How do I fix CVE-2018-11615?

Upgrade mosca to 2.8.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-11615 being exploited?

There is no known exploitation of CVE-2018-11615 in the wild and no public exploit code.

Sources

Also known as GHSA-wqg7-vrj7-v82h.

Is CVE-2018-11615 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free