# CVE-2018-11615: Mosca REDoS Vulnerability

> Remote attackers can crash the MQTT broker by sending crafted regular expressions in topic processing, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wqg7-vrj7-v82h

## What is CVE-2018-11615?

CVE-2018-11615 is a high-severity denial of service vulnerability in npm mosca, published on 30 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This vulnerability allows remote attackers to deny service on vulnerable installations of npm mosca 2.8.1. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of topics. A crafted regular expression can cause the broker to crash. An attacker can leverage this vulnerability to deny access to the target system. Was ZDI-CAN-6306.

Weakness: CWE-185 (Incorrect Regular Expression), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-11615?

2 open source packages ship an affected version, including mosca. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mosca` | npm | All versions | 2.8.2 |
| `mosca` | npm | All versions | 2.8.2 |

Products: Mosca Project Mosca.

## How do I fix CVE-2018-11615?

Upgrade mosca to 2.8.2 or later.

## Is CVE-2018-11615 being exploited?

There is no known exploitation of CVE-2018-11615 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11615 and fix it if it is affected.

What it is: CVE-2018-11615 is a high-severity denial of service vulnerability in npm mosca, published on 30 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11615 in the wild and no public exploit code.

Affected packages and fixed versions:
- mosca (npm): affected all versions; fixed in 2.8.2
- mosca (npm): affected all versions; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11615/ (Markdown: https://insights.sbomify.com/CVE-2018-11615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11615
- OSV: https://osv.dev/vulnerability/CVE-2018-11615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11615/
Summaries are generated and may contain mistakes; the official description above is the record.
