# CVE-2018-11651: Cross-site Scripting in Graylog

> Attackers can inject malicious scripts via dashboard names in Graylog, potentially executing code or hijacking user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-435g-r2m8-gjvm

## What is CVE-2018-11651?

CVE-2018-11651 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Graylog before v2.4.4 has an XSS security issue with unescaped text in dashboard names, related to components/dashboard/Dashboard.jsx, components/dashboard/EditDashboardModal.jsx, and pages/ShowDashboardPage.jsx.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-11651?

2 open source packages ship an affected version, including org.graylog2:graylog2-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | All versions | 2.4.4 |
| `org.graylog2:graylog2-server` | Maven | All versions | 2.4.4 |

Products: Graylog Graylog.

## How do I fix CVE-2018-11651?

Upgrade org.graylog2:graylog2-server to 2.4.4 or later.

## Is CVE-2018-11651 being exploited?

There is no known exploitation of CVE-2018-11651 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-37759](https://insights.sbomify.com/CVE-2021-37759/): Information disclosure in n/a (critical 9.8)
- [CVE-2021-37760](https://insights.sbomify.com/CVE-2021-37760/): Information disclosure in n/a (critical 9.8)
- [CVE-2026-1435](https://insights.sbomify.com/CVE-2026-1435/): Incorrect management of session invalidation vulnerability in Graylog Web Interface (critical 9.3)
- [CVE-2025-53106](https://insights.sbomify.com/CVE-2025-53106/): Graylog vulnerable to privilege escalation through API tokens (high 8.8)
- [CVE-2024-24824](https://insights.sbomify.com/CVE-2024-24824/): graylog2-server vulnerable to instantiation of arbitrary classes triggered by API request (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11651 and fix it if it is affected.

What it is: CVE-2018-11651 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11651 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected all versions; fixed in 2.4.4
- org.graylog2:graylog2-server (Maven): affected all versions; fixed in 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11651/ (Markdown: https://insights.sbomify.com/CVE-2018-11651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11651
- OSV: https://osv.dev/vulnerability/CVE-2018-11651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11651/
Summaries are generated and may contain mistakes; the official description above is the record.
