# CVE-2018-11688: Ignite Realtime Openfire vulnerable to cross-site scripting

> Remote attackers can execute scripts in victims' browsers via crafted URLs to steal authentication credentials in Openfire.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jphj-5g3m-w7x6

## What is CVE-2018-11688?

CVE-2018-11688 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-11688?

2 open source packages ship an affected version, including org.igniterealtime.openfire:parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 3.9.2 |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 3.9.2 |

Products: Igniterealtime Openfire.

## How do I fix CVE-2018-11688?

Upgrade org.igniterealtime.openfire:parent to 3.9.2 or later.

## Is CVE-2018-11688 being exploited?

There is no known exploitation of CVE-2018-11688 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-32315](https://insights.sbomify.com/CVE-2023-32315/): Ignite Realtime Openfire Path Traversal (high 8.6, exploited in the wild)
- [CVE-2024-25421](https://insights.sbomify.com/CVE-2024-25421/): Ignite Realtime Openfire privilege escalation vulnerability (critical 9.8)
- [CVE-2021-45967](https://insights.sbomify.com/CVE-2021-45967/): Path traversal in n/a (critical 9.8)
- [CVE-2019-18394](https://insights.sbomify.com/CVE-2019-18394/): Ignite Realtime Openfire vulnerable to Server Side Request Forgery (critical 9.8)
- [CVE-2014-2741](https://insights.sbomify.com/CVE-2014-2741/): Ignite Realtime Openfire vulnerable to XMPPbomb attack (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11688 and fix it if it is affected.

What it is: CVE-2018-11688 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11688 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.9.2
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11688/ (Markdown: https://insights.sbomify.com/CVE-2018-11688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11688
- OSV: https://osv.dev/vulnerability/CVE-2018-11688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11688/
Summaries are generated and may contain mistakes; the official description above is the record.
