# CVE-2018-11764: Authentication bypass in Apache Hadoop

> Authenticated users can impersonate any user in Apache Hadoop due to broken web endpoint authentication checks, allowing unauthorized access and privilege escalation.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4fh8-pm7g-pmxq

## What is CVE-2018-11764?

CVE-2018-11764 is a high-severity authentication bypass vulnerability in Apache Hadoop, published on 21 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Web endpoint authentication check is broken in Apache Hadoop 3.0.0-alpha4, 3.0.0-beta1, and 3.0.0. Authenticated users may impersonate any user even if no proxy user is configured.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2018-11764?

6 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.hadoop:hadoop-main` | Maven | From 3.0.0 | 3.0.1 |
| `org.apache.hadoop:hadoop-main` | Maven | From 3.0.0 | 3.0.1 |
| `org.apache.hadoop:hadoop-main` | Maven | From 3.0.0-alpha4 | 3.0.1 |
| `org.apache.hadoop:hadoop-main` | Maven | From 3.0.0-alpha4 | 3.0.1 |
| `org.apache.hadoop:hadoop-main` | Maven | From 3.0.0-beta1 | 3.0.1 |
| `org.apache.hadoop:hadoop-main` | Maven | From 3.0.0-beta1 | 3.0.1 |

Products: Apache Hadoop.

## How do I fix CVE-2018-11764?

Upgrade org.apache.hadoop:hadoop-main to 3.0.1 or later.

## Is CVE-2018-11764 being exploited?

There is no known exploitation of CVE-2018-11764 in the wild and no public exploit code.

## Other vulnerabilities in Apache Hadoop

- [CVE-2022-25168](https://insights.sbomify.com/CVE-2022-25168/): Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar (critical 9.8)
- [CVE-2021-37404](https://insights.sbomify.com/CVE-2021-37404/): Heap buffer overflow in libhdfs native library (critical 9.8)
- [CVE-2022-26612](https://insights.sbomify.com/CVE-2022-26612/): Arbitrary file write in FileUtil#unpackEntries on Windows (critical 9.8)
- [CVE-2019-17195](https://insights.sbomify.com/CVE-2019-17195/): Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT (critical 9.8)
- [CVE-2017-15718](https://insights.sbomify.com/CVE-2017-15718/): Exposure of Sensitive Information in Hadoop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11764 and fix it if it is affected.

What it is: CVE-2018-11764 is a high-severity authentication bypass vulnerability in Apache Hadoop, published on 21 Oct 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11764 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.hadoop:hadoop-main (Maven): affected from 3.0.0; fixed in 3.0.1
- org.apache.hadoop:hadoop-main (Maven): affected from 3.0.0; fixed in 3.0.1
- org.apache.hadoop:hadoop-main (Maven): affected from 3.0.0-alpha4; fixed in 3.0.1
- org.apache.hadoop:hadoop-main (Maven): affected from 3.0.0-alpha4; fixed in 3.0.1
- org.apache.hadoop:hadoop-main (Maven): affected from 3.0.0-beta1; fixed in 3.0.1
- org.apache.hadoop:hadoop-main (Maven): affected from 3.0.0-beta1; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11764/ (Markdown: https://insights.sbomify.com/CVE-2018-11764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11764
- OSV: https://osv.dev/vulnerability/CVE-2018-11764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11764/
Summaries are generated and may contain mistakes; the official description above is the record.
