{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.hadoop:hadoop-main. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-11766 in the wild and no public exploit code.","fix":"Upgrade org.apache.hadoop:hadoop-main to 2.7.7 or later.","what":"CVE-2018-11766 is a high-severity vulnerability in Apache Hadoop, published on 27 Nov 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-11766 and fix it if it is affected.\n\nWhat it is: CVE-2018-11766 is a high-severity vulnerability in Apache Hadoop, published on 27 Nov 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-11766 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.hadoop:hadoop-main (Maven): affected from 2.7.4; fixed in 2.7.7\n- org.apache.hadoop:hadoop-main (Maven): affected from 2.7.4; fixed in 2.7.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11766/ (Markdown: https://insights.sbomify.com/CVE-2018-11766/index.md)","id":"CVE-2018-11766","markdown":"https://insights.sbomify.com/CVE-2018-11766/index.md","name":"CVE-2018-11766","record":{"aliases":["GHSA-rqj9-cq6j-958r"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Hadoop YARN","requires_auth":"low_privilege","summary":"An attacker with yarn user access can escalate privileges to root and execute arbitrary commands in Apache Hadoop.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"hadoop","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"In Apache Hadoop 2.7.4 to 2.7.6, the security fix for CVE-2016-6811 is incomplete. A user who can escalate to yarn user can possibly run arbitrary commands as root user.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Command Execution in Hadoop","id":"CVE-2018-11766","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Improper Privilege Management in org.apache.hadoop:hadoop-main","id":"CVE-2018-11767"},"packages":[{"ecosystem":"Maven","fixed":["2.7.7"],"introduced":["2.7.4"],"last_affected":[],"package":"org.apache.hadoop:hadoop-main","purl":null,"source":"GHSA-rqj9-cq6j-958r"},{"ecosystem":"Maven","fixed":["2.7.7"],"introduced":["2.7.4"],"last_affected":[],"package":"org.apache.hadoop:hadoop-main","purl":"pkg:maven/org.apache.hadoop/hadoop-main","source":"GHSA-rqj9-cq6j-958r"}],"prev":{"headline":"Improper Authentication in Apache Hadoop","id":"CVE-2018-11765"},"products":["Apache Hadoop"],"published":"2018-11-27","related":[{"cvss_score":9.8,"headline":"Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar","id":"CVE-2022-25168","kev_date_added":null,"published":"2022-08-04"},{"cvss_score":9.8,"headline":"Heap buffer overflow in libhdfs native library","id":"CVE-2021-37404","kev_date_added":null,"published":"2022-06-13"},{"cvss_score":9.8,"headline":"Arbitrary file write in FileUtil#unpackEntries on Windows","id":"CVE-2022-26612","kev_date_added":null,"published":"2022-04-07"},{"cvss_score":9.8,"headline":"Improper Check for Unusual or Exceptional Conditions in Connect2id Nimbus JOSE+JWT","id":"CVE-2019-17195","kev_date_added":null,"published":"2019-10-15"},{"cvss_score":9.8,"headline":"Exposure of Sensitive Information in Hadoop","id":"CVE-2017-15718","kev_date_added":null,"published":"2018-01-24"},{"cvss_score":9.8,"headline":"Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop","id":"CVE-2012-4449","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":9.8,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache Hadoop","id":"CVE-2016-3086","kev_date_added":null,"published":"2017-09-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Apache Software Foundation"]},"summary":"An attacker with yarn user access can escalate privileges to root and execute arbitrary commands in Apache Hadoop.","url":"https://insights.sbomify.com/CVE-2018-11766/"}