# CVE-2018-11775: Improper Certificate Validation in Apache activemq-client

> Missing TLS hostname verification in the ActiveMQ client allows attackers to perform man-in-the-middle attacks, intercepting or modifying data.

- **Severity:** High 7.4 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Sep 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-11775, GHSA-m9w8-v359-9ffr, UBUNTU-CVE-2018-11775

## What is CVE-2018-11775?

CVE-2018-11775 is a high-severity vulnerability in Apache Activemq, published on 10 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2018-11775?

2 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.15.6 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.15.6 |

Products: Apache Activemq, Oracle Enterprise Repository, Oracle Flexcube Private Banking.

## How do I fix CVE-2018-11775?

Upgrade org.apache.activemq:activemq-client to 5.15.6 or later.

## Is CVE-2018-11775 being exploited?

There is no known exploitation of CVE-2018-11775 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11775 and fix it if it is affected.

What it is: CVE-2018-11775 is a high-severity vulnerability in Apache Activemq, published on 10 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11775 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.15.6
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.15.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11775/ (Markdown: https://insights.sbomify.com/CVE-2018-11775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11775
- OSV: https://osv.dev/vulnerability/CVE-2018-11775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11775/
Summaries are generated and may contain mistakes; the official description above is the record.
