CVE-2018-11777 Improper Authentication in hive:hive-exec

High 8.1 Published Updated

Attackers can access local resources on HiveServer2 machines if authorization plugins like Ranger or Sentry are not enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-11777?

CVE-2018-11777 is a high-severity missing authorization vulnerability in Apache Hive, published on 8 Nov 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.

Which versions are affected by CVE-2018-11777?

4 open source packages ship an affected version, including org.apache.hive:hive-exec. It affects 1 product.

PackageAffectedFixed in
org.apache.hive:hive-exec MavenAll versions2.3.4
org.apache.hive:hive-exec MavenAll versions2.3.4
org.apache.hive:hive-exec MavenFrom 3.0.03.1.1
org.apache.hive:hive-exec MavenFrom 3.0.03.1.1

Products include Apache Hive.

How do I fix CVE-2018-11777?

Upgrade org.apache.hive:hive-exec to a fixed version for your release line: 2.3.4 or 3.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2018-11777 being exploited?

There is no known exploitation of CVE-2018-11777 in the wild and no public exploit code.

Sources

Also known as GHSA-rrfq-g5fq-fc9c.

Is CVE-2018-11777 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free