{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.hive:hive-exec. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-11777 in the wild and no public exploit code.","fix":"Upgrade org.apache.hive:hive-exec to a fixed version for your release line: 2.3.4 or 3.1.1.","what":"CVE-2018-11777 is a high-severity missing authorization vulnerability in Apache Hive, published on 8 Nov 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-11777 and fix it if it is affected.\n\nWhat it is: CVE-2018-11777 is a high-severity missing authorization vulnerability in Apache Hive, published on 8 Nov 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-11777 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 2.3.4\n- org.apache.hive:hive-exec (Maven): affected all versions; fixed in 2.3.4\n- org.apache.hive:hive-exec (Maven): affected from 3.0.0; fixed in 3.1.1\n- org.apache.hive:hive-exec (Maven): affected from 3.0.0; fixed in 3.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11777/ (Markdown: https://insights.sbomify.com/CVE-2018-11777/index.md)","id":"CVE-2018-11777","markdown":"https://insights.sbomify.com/CVE-2018-11777/index.md","name":"CVE-2018-11777","record":{"aliases":["GHSA-rrfq-g5fq-fc9c"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Hive","requires_auth":"low_privilege","summary":"Attackers can access local resources on HiveServer2 machines if authorization plugins like Ranger or Sentry are not enabled.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"hive","vendor":"apache"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[],"description":"In Apache Hive 2.3.3, 3.1.0 and earlier, local resources on HiveServer2 machines are not properly protected against malicious user if ranger, sentry or sql standard authorizer is not in use.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Authentication in hive:hive-exec","id":"CVE-2018-11777","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2018"},"n_packages":4,"n_references":2,"next":{"headline":"UnixAuthenticationService in Apache Ranger was updated to correctly handle user input to avoid Stack-based buffer overflow","id":"CVE-2018-11778"},"packages":[{"ecosystem":"Maven","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.hive:hive-exec","purl":null,"source":"GHSA-rrfq-g5fq-fc9c"},{"ecosystem":"Maven","fixed":["2.3.4"],"introduced":["0"],"last_affected":[],"package":"org.apache.hive:hive-exec","purl":"pkg:maven/org.apache.hive/hive-exec","source":"GHSA-rrfq-g5fq-fc9c"},{"ecosystem":"Maven","fixed":["3.1.1"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.hive:hive-exec","purl":null,"source":"GHSA-rrfq-g5fq-fc9c"},{"ecosystem":"Maven","fixed":["3.1.1"],"introduced":["3.0.0"],"last_affected":[],"package":"org.apache.hive:hive-exec","purl":"pkg:maven/org.apache.hive/hive-exec","source":"GHSA-rrfq-g5fq-fc9c"}],"prev":{"headline":"Apache Struts Remote Code Execution","id":"CVE-2018-11776"},"products":["Apache Hive"],"published":"2018-11-08","related":[{"cvss_score":9.8,"headline":"Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths","id":"CVE-2026-49845","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in Jodd","id":"CVE-2018-21234","kev_date_added":null,"published":"2020-05-21"},{"cvss_score":9.1,"headline":"Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url","id":"CVE-2026-55976","kev_date_added":null,"published":"2026-08-25"},{"cvss_score":9.1,"headline":"SQL Injection in hive-jdbc","id":"CVE-2018-1282","kev_date_added":null,"published":"2018-04-05"},{"cvss_score":8.3,"headline":"Apache Hive: Deserialization of untrusted data when fetching partitions from the Metastore","id":"CVE-2022-41137","kev_date_added":null,"published":"2024-12-05"},{"cvss_score":8.3,"headline":"High severity vulnerability that affects org.apache.hive:hive, org.apache.hive:hive-exec, and org.apache.hive:hive-service","id":"CVE-2015-7521","kev_date_added":null,"published":"2016-01-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Apache Software Foundation"]},"summary":"Attackers can access local resources on HiveServer2 machines if authorization plugins like Ranger or Sentry are not enabled.","url":"https://insights.sbomify.com/CVE-2018-11777/"}