{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-11778 in the wild and no public exploit code.","fix":"Upgrade org.apache.ranger:ranger to 1.2.0 or later.","what":"CVE-2018-11778 is a high-severity memory corruption vulnerability in Apache Ranger, published on 5 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-11778 and fix it if it is affected.\n\nWhat it is: CVE-2018-11778 is a high-severity memory corruption vulnerability in Apache Ranger, published on 5 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-11778 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ranger:ranger (Maven): affected all versions; fixed in 1.2.0\n- org.apache.ranger:ranger (Maven): affected all versions; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11778/ (Markdown: https://insights.sbomify.com/CVE-2018-11778/index.md)","id":"CVE-2018-11778","markdown":"https://insights.sbomify.com/CVE-2018-11778/index.md","name":"CVE-2018-11778","record":{"aliases":["GHSA-c99h-fgqm-6679"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Ranger","requires_auth":"low_privilege","summary":"A stack-based buffer overflow in Apache Ranger's UnixAuthenticationService allows attackers to execute arbitrary code or cause denial of service.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ranger","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"UnixAuthenticationService in Apache Ranger 1.2.0 was updated to correctly handle user input to avoid Stack-based buffer overflow. Versions prior to 1.2.0 should be upgraded to 1.2.0","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"UnixAuthenticationService in Apache Ranger was updated to correctly handle user input to avoid Stack-based buffer overflow","id":"CVE-2018-11778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"memory_corruption","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"Deserialization of Untrusted Data in Apache Storm","id":"CVE-2018-11779"},"packages":[{"ecosystem":"Maven","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.ranger:ranger","purl":null,"source":"GHSA-c99h-fgqm-6679"},{"ecosystem":"Maven","fixed":["1.2.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.ranger:ranger","purl":"pkg:maven/org.apache.ranger/ranger","source":"GHSA-c99h-fgqm-6679"}],"prev":{"headline":"Improper Authentication in hive:hive-exec","id":"CVE-2018-11777"},"products":["Apache Ranger"],"published":"2018-10-05","related":[{"cvss_score":9.8,"headline":"Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder","id":"CVE-2026-28672","kev_date_added":null,"published":"2026-08-10"},{"cvss_score":9.8,"headline":"Apache Ranger: SQL Injection vulnerability in lookup functionality","id":"CVE-2026-32227","kev_date_added":null,"published":"2026-08-10"},{"cvss_score":9.8,"headline":"Apache Ranger: Privilege Escalation via URL Parameter","id":"CVE-2026-40920","kev_date_added":null,"published":"2026-08-10"},{"cvss_score":9.8,"headline":"Apache Ranger: Remote Code Execution via JDBC URL Injection","id":"CVE-2026-42537","kev_date_added":null,"published":"2026-08-10"},{"cvss_score":9.8,"headline":"Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation","id":"CVE-2026-44416","kev_date_added":null,"published":"2026-08-10"},{"cvss_score":9.8,"headline":"Apache Ranger: Remote Code Execution Vulnerability in GraalScriptEngineCreator","id":"CVE-2026-55799","kev_date_added":null,"published":"2026-08-10"},{"cvss_score":9.8,"headline":"Apache Ranger: Remote Code Execution Vulnerability in NashornScriptEngineCreator","id":"CVE-2025-59059","kev_date_added":null,"published":"2026-03-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"A stack-based buffer overflow in Apache Ranger's UnixAuthenticationService allows attackers to execute arbitrary code or cause denial of service.","url":"https://insights.sbomify.com/CVE-2018-11778/"}