# CVE-2018-11778: UnixAuthenticationService in Apache Ranger was updated to correctly handle user input to avoid Stack-based buffer overflow

> A stack-based buffer overflow in Apache Ranger's UnixAuthenticationService allows attackers to execute arbitrary code or cause denial of service.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Oct 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-c99h-fgqm-6679

## What is CVE-2018-11778?

CVE-2018-11778 is a high-severity memory corruption vulnerability in Apache Ranger, published on 5 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

UnixAuthenticationService in Apache Ranger 1.2.0 was updated to correctly handle user input to avoid Stack-based buffer overflow. Versions prior to 1.2.0 should be upgraded to 1.2.0

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2018-11778?

2 open source packages ship an affected version, including org.apache.ranger:ranger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ranger:ranger` | Maven | All versions | 1.2.0 |
| `org.apache.ranger:ranger` | Maven | All versions | 1.2.0 |

Products: Apache Ranger.

## How do I fix CVE-2018-11778?

Upgrade org.apache.ranger:ranger to 1.2.0 or later.

## Is CVE-2018-11778 being exploited?

There is no known exploitation of CVE-2018-11778 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ranger

- [CVE-2026-28672](https://insights.sbomify.com/CVE-2026-28672/): Apache Ranger: OS Command Injection via Username in UnixUserGroupBuilder (critical 9.8)
- [CVE-2026-32227](https://insights.sbomify.com/CVE-2026-32227/): Apache Ranger: SQL Injection vulnerability in lookup functionality (critical 9.8)
- [CVE-2026-40920](https://insights.sbomify.com/CVE-2026-40920/): Apache Ranger: Privilege Escalation via URL Parameter (critical 9.8)
- [CVE-2026-42537](https://insights.sbomify.com/CVE-2026-42537/): Apache Ranger: Remote Code Execution via JDBC URL Injection (critical 9.8)
- [CVE-2026-44416](https://insights.sbomify.com/CVE-2026-44416/): Apache Ranger: Remote Code Execution via Arbitrary Class Instantiation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11778 and fix it if it is affected.

What it is: CVE-2018-11778 is a high-severity memory corruption vulnerability in Apache Ranger, published on 5 Oct 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11778 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ranger:ranger (Maven): affected all versions; fixed in 1.2.0
- org.apache.ranger:ranger (Maven): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11778/ (Markdown: https://insights.sbomify.com/CVE-2018-11778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11778
- OSV: https://osv.dev/vulnerability/CVE-2018-11778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11778/
Summaries are generated and may contain mistakes; the official description above is the record.
