CVE-2018-11787 Improper Authentication in Apache Karaf
Unauthenticated attackers can access the Karaf Gogo console via an unsecured URL when the Pax Web Extender Whiteboard is installed, allowing command execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-11787?
CVE-2018-11787 is a high-severity authentication bypass vulnerability in Apache Karaf, published on 18 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Apache Karaf version prior to 3.0.9, 4.0.9, 4.1.1, when the webconsole feature is installed in Karaf, it is available at .../system/console and requires authentication to access it. One part of the console is a Gogo shell/console that gives access to the command line console of Karaf via a Web browser, and when navigated to it is available at .../system/console/gogo. Trying to go directly to that URL does require authentication. And optional bundle that some applications use is the Pax Web Extender Whiteboard, it is part of the pax-war feature and perhaps others. When it is installed, the Gogo console becomes available at another URL .../gogo/, and that URL is not secured giving access to the Karaf console to unauthenticated users. A mitigation for the issue is to manually stop/uninstall Gogo plugin bundle that is installed with the webconsole feature, although of course this removes the console from the .../system/console application, not only from the unauthenticated endpoint. One could also stop/uninstall the Pax Web Extender Whiteboard, but other components/applications may require it and so their functionality would be reduced/compromised.
Weakness: CWE-287
Which versions are affected by CVE-2018-11787?
6 open source packages ship an affected version, including org.apache.karaf:apache-karaf. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.karaf:apache-karaf Maven | All versions | 3.0.9 |
org.apache.karaf:apache-karaf Maven | All versions | 3.0.9 |
org.apache.karaf:apache-karaf Maven | From 4.0.0 | 4.0.9 |
org.apache.karaf:apache-karaf Maven | From 4.0.0 | 4.0.9 |
org.apache.karaf:apache-karaf Maven | From 4.1.0 | 4.1.1 |
org.apache.karaf:apache-karaf Maven | From 4.1.0 | 4.1.1 |
Products include Apache Karaf.
How do I fix CVE-2018-11787?
Upgrade org.apache.karaf:apache-karaf to a fixed version for your release line: 3.0.9, 4.0.9 or 4.1.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2018-11787 being exploited?
There is no known exploitation of CVE-2018-11787 in the wild and no public exploit code.
Other vulnerabilities in Apache Karaf
- CVE-2026-91012 Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation
- CVE-2026-91048 Missing authorization in Apache Karaf
- CVE-2022-40145 Apache Karaf: JDBC JAAS LDAP injection
- CVE-2018-11788 XML External Entity Reference in Apache Karaf
- CVE-2026-92142 Apache Karaf: Authorization bypass in JMX MBean lifecycle operations
Sources
Also known as GHSA-cq9c-55r7-455x.