# CVE-2018-11787: Improper Authentication in Apache Karaf

> Unauthenticated attackers can access the Karaf Gogo console via an unsecured URL when the Pax Web Extender Whiteboard is installed, allowing command execution.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Sep 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-cq9c-55r7-455x

## What is CVE-2018-11787?

CVE-2018-11787 is a high-severity authentication bypass vulnerability in Apache Karaf, published on 18 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Karaf version prior to 3.0.9, 4.0.9, 4.1.1, when the webconsole feature is installed in Karaf, it is available at .../system/console and requires authentication to access it. One part of the console is a Gogo shell/console that gives access to the command line console of Karaf via a Web browser, and when navigated to it is available at .../system/console/gogo. Trying to go directly to that URL does require authentication. And optional bundle that some applications use is the Pax Web Extender Whiteboard, it is part of the pax-war feature and perhaps others. When it is installed, the Gogo console becomes available at another URL .../gogo/, and that URL is not secured giving access to the Karaf console to unauthenticated users. A mitigation for the issue is to manually stop/uninstall Gogo plugin bundle that is installed with the webconsole feature, although of course this removes the console from the .../system/console application, not only from the unauthenticated endpoint. One could also stop/uninstall the Pax Web Extender Whiteboard, but other components/applications may require it and so their functionality would be reduced/compromised.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2018-11787?

6 open source packages ship an affected version, including org.apache.karaf:apache-karaf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 3.0.9 |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 3.0.9 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.0.0 | 4.0.9 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.0.0 | 4.0.9 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.1.0 | 4.1.1 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.1.0 | 4.1.1 |

Products: Apache Karaf.

## How do I fix CVE-2018-11787?

Upgrade org.apache.karaf:apache-karaf to a fixed version for your release line: 3.0.9, 4.0.9 or 4.1.1.

## Is CVE-2018-11787 being exploited?

There is no known exploitation of CVE-2018-11787 in the wild and no public exploit code.

## Other vulnerabilities in Apache Karaf

- [CVE-2026-91012](https://insights.sbomify.com/CVE-2026-91012/): Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation (critical 9.8)
- [CVE-2026-91048](https://insights.sbomify.com/CVE-2026-91048/): Missing authorization in Apache Karaf (critical 9.8)
- [CVE-2022-40145](https://insights.sbomify.com/CVE-2022-40145/): Apache Karaf: JDBC JAAS LDAP injection (critical 9.8)
- [CVE-2018-11788](https://insights.sbomify.com/CVE-2018-11788/): XML External Entity Reference in Apache Karaf (critical 9.8)
- [CVE-2026-92142](https://insights.sbomify.com/CVE-2026-92142/): Apache Karaf: Authorization bypass in JMX MBean lifecycle operations (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11787 and fix it if it is affected.

What it is: CVE-2018-11787 is a high-severity authentication bypass vulnerability in Apache Karaf, published on 18 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11787 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 3.0.9
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 3.0.9
- org.apache.karaf:apache-karaf (Maven): affected from 4.0.0; fixed in 4.0.9
- org.apache.karaf:apache-karaf (Maven): affected from 4.0.0; fixed in 4.0.9
- org.apache.karaf:apache-karaf (Maven): affected from 4.1.0; fixed in 4.1.1
- org.apache.karaf:apache-karaf (Maven): affected from 4.1.0; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11787/ (Markdown: https://insights.sbomify.com/CVE-2018-11787/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11787
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11787
- OSV: https://osv.dev/vulnerability/CVE-2018-11787

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11787/
Summaries are generated and may contain mistakes; the official description above is the record.
