# CVE-2018-11788: XML External Entity Reference in Apache Karaf

> An attacker can exploit XML External Entity injection in Apache Karaf's features deployer to read sensitive files or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-92wj-x78c-m4fx

## What is CVE-2018-11788?

CVE-2018-11788 is a critical vulnerability in Apache Karaf, published on 7 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Karaf provides a features deployer, which allows users to "hot deploy" a features XML by dropping the file directly in the deploy folder. The features XML is parsed by XMLInputFactory class. Apache Karaf XMLInputFactory class doesn't contain any mitigation codes against XXE. This is a potential security risk as an user can inject external XML entities in Apache Karaf version prior to 4.1.7 or 4.2.2. It has been fixed in Apache Karaf 4.1.7 and 4.2.2 releases.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-11788?

4 open source packages ship an affected version, including org.apache.karaf.specs:org.apache.karaf.specs.java.xml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.karaf.specs:org.apache.karaf.specs.java.xml` | Maven | All versions | 4.1.7 |
| `org.apache.karaf.specs:org.apache.karaf.specs.java.xml` | Maven | All versions | 4.1.7 |
| `org.apache.karaf.specs:org.apache.karaf.specs.java.xml` | Maven | From 4.2.0 | 4.2.2 |
| `org.apache.karaf.specs:org.apache.karaf.specs.java.xml` | Maven | From 4.2.0 | 4.2.2 |

Products: Apache Karaf.

## How do I fix CVE-2018-11788?

Upgrade org.apache.karaf.specs:org.apache.karaf.specs.java.xml to a fixed version for your release line: 4.1.7 or 4.2.2.

## Is CVE-2018-11788 being exploited?

There is no known exploitation of CVE-2018-11788 in the wild and no public exploit code.

Public exploit code:

- Apache Karaf XXE Vulnerability (CVE-2018-11788) (github_poc): https://github.com/brianwrf/CVE-2018-11788

## Other vulnerabilities in Apache Karaf

- [CVE-2026-91012](https://insights.sbomify.com/CVE-2026-91012/): Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation (critical 9.8)
- [CVE-2026-91048](https://insights.sbomify.com/CVE-2026-91048/): Missing authorization in Apache Karaf (critical 9.8)
- [CVE-2022-40145](https://insights.sbomify.com/CVE-2022-40145/): Apache Karaf: JDBC JAAS LDAP injection (critical 9.8)
- [CVE-2026-92142](https://insights.sbomify.com/CVE-2026-92142/): Apache Karaf: Authorization bypass in JMX MBean lifecycle operations (high 8.8)
- [CVE-2026-91006](https://insights.sbomify.com/CVE-2026-91006/): Apache Karaf: OS Command Injection in Child-Instance Launch (instance:* / InstancesMBean) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11788 and fix it if it is affected.

What it is: CVE-2018-11788 is a critical vulnerability in Apache Karaf, published on 7 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11788 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.karaf.specs:org.apache.karaf.specs.java.xml (Maven): affected all versions; fixed in 4.1.7
- org.apache.karaf.specs:org.apache.karaf.specs.java.xml (Maven): affected all versions; fixed in 4.1.7
- org.apache.karaf.specs:org.apache.karaf.specs.java.xml (Maven): affected from 4.2.0; fixed in 4.2.2
- org.apache.karaf.specs:org.apache.karaf.specs.java.xml (Maven): affected from 4.2.0; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11788/ (Markdown: https://insights.sbomify.com/CVE-2018-11788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11788
- OSV: https://osv.dev/vulnerability/CVE-2018-11788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11788/
Summaries are generated and may contain mistakes; the official description above is the record.
