CVE-2018-11796 Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack

High 7.5 Published Updated

Attackers can cause denial of service via XML entity expansion in Apache Tika due to improper parser reset handling.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-11796?

CVE-2018-11796 is a high-severity vulnerability in Apache Tika, published on 9 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Weakness: CWE-611

Which versions are affected by CVE-2018-11796?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.

PackageAffectedFixed in
org.apache.tika:tika-core MavenFrom 0.11.19.1
org.apache.tika:tika-core MavenFrom 0.11.19.1

Products include Apache Tika.

How do I fix CVE-2018-11796?

Upgrade org.apache.tika:tika-core to 1.19.1 or later.

Is CVE-2018-11796 being exploited?

There is no known exploitation of CVE-2018-11796 in the wild and no public exploit code.

Sources

Also known as GHSA-h8q5-g2cj-qr5h, UBUNTU-CVE-2018-11796.

Is CVE-2018-11796 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free