# CVE-2018-11796: Apache Tika is vulnerable to entity expansions which can lead to a denial of service attack

> Attackers can cause denial of service via XML entity expansion in Apache Tika due to improper parser reset handling.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h8q5-g2cj-qr5h, UBUNTU-CVE-2018-11796

## What is CVE-2018-11796?

CVE-2018-11796 is a high-severity vulnerability in Apache Tika, published on 9 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-11796?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-core` | Maven | From 0.1 | 1.19.1 |
| `org.apache.tika:tika-core` | Maven | From 0.1 | 1.19.1 |

Products: Apache Tika.

## How do I fix CVE-2018-11796?

Upgrade org.apache.tika:tika-core to 1.19.1 or later.

## Is CVE-2018-11796 being exploited?

There is no known exploitation of CVE-2018-11796 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tika

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2025-54988](https://insights.sbomify.com/CVE-2025-54988/): Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA (high 8.4)
- [CVE-2018-1335](https://insights.sbomify.com/CVE-2018-1335/): Command injection in org.apache.tika:tika-core (high 8.1)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11796 and fix it if it is affected.

What it is: CVE-2018-11796 is a high-severity vulnerability in Apache Tika, published on 9 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11796 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tika:tika-core (Maven): affected from 0.1; fixed in 1.19.1
- org.apache.tika:tika-core (Maven): affected from 0.1; fixed in 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11796/ (Markdown: https://insights.sbomify.com/CVE-2018-11796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11796
- OSV: https://osv.dev/vulnerability/CVE-2018-11796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11796/
Summaries are generated and may contain mistakes; the official description above is the record.
