# CVE-2018-11798: Apache Thrift Node.js static web server sandbox escape

> Remote attackers can access files outside the web server's root directory in the Apache Thrift Node.js static web server.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jan 2019
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2026-AF38253, CLEANSTART-2026-NC43548, DEBIAN-CVE-2018-11798, ECHO-17dc-b122-1852, GHSA-vx85-mj8c-4qm6

## What is CVE-2018-11798?

CVE-2018-11798 is a medium-severity path traversal vulnerability in Apache Thrift, published on 7 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Apache Thrift Node.js static web server in versions 0.9.2 through 0.11.0 have been determined to contain a security vulnerability in which a remote user has the ability to access files outside the set webservers docroot path.

Weakness: CWE-538 (Insertion of Sensitive Information into Externally-Accessible File or Directory)

## Which versions are affected by CVE-2018-11798?

2 open source packages ship an affected version, including org.apache.thrift:libthrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.thrift:libthrift` | Maven | From 0.9.2 | 0.12.0 |
| `org.apache.thrift:libthrift` | Maven | From 0.9.2 | 0.12.0 |

Products: Apache Thrift.

## How do I fix CVE-2018-11798?

Upgrade org.apache.thrift:libthrift to 0.12.0 or later.

## Is CVE-2018-11798 being exploited?

There is no known exploitation of CVE-2018-11798 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11798 and fix it if it is affected.

What it is: CVE-2018-11798 is a medium-severity path traversal vulnerability in Apache Thrift, published on 7 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11798 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.thrift:libthrift (Maven): affected from 0.9.2; fixed in 0.12.0
- org.apache.thrift:libthrift (Maven): affected from 0.9.2; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11798/ (Markdown: https://insights.sbomify.com/CVE-2018-11798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11798
- OSV: https://osv.dev/vulnerability/CVE-2018-11798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11798/
Summaries are generated and may contain mistakes; the official description above is the record.
