{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.oozie:oozie-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-11799 in the wild and no public exploit code.","fix":"Upgrade org.apache.oozie:oozie-core to 5.1.0 or later.","what":"CVE-2018-11799 is a medium-severity authentication bypass vulnerability in Apache Oozie, published on 19 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-11799 and fix it if it is affected.\n\nWhat it is: CVE-2018-11799 is a medium-severity authentication bypass vulnerability in Apache Oozie, published on 19 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-11799 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.oozie:oozie-core (Maven): affected all versions; fixed in 5.1.0\n- org.apache.oozie:oozie-core (Maven): affected all versions; fixed in 5.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11799/ (Markdown: https://insights.sbomify.com/CVE-2018-11799/index.md)","id":"CVE-2018-11799","markdown":"https://insights.sbomify.com/CVE-2018-11799/index.md","name":"CVE-2018-11799","record":{"aliases":["GHSA-wg5w-vv93-3f7w"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Oozie workflow scheduler","requires_auth":"low_privilege","summary":"A malicious user can impersonate other users by crafting specific XML, allowing workflows to run under other users' identities.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"oozie","vendor":"apache"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Vulnerability allows a user of Apache Oozie 3.1.3-incubating to 5.0.0 to impersonate other users. The malicious user can construct an XML that results workflows running in other user's name.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects org.apache.oozie:oozie-core","id":"CVE-2018-11799","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"SQL injection in Apache Fineract","id":"CVE-2018-11800"},"packages":[{"ecosystem":"Maven","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.oozie:oozie-core","purl":null,"source":"GHSA-wg5w-vv93-3f7w"},{"ecosystem":"Maven","fixed":["5.1.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.oozie:oozie-core","purl":"pkg:maven/org.apache.oozie/oozie-core","source":"GHSA-wg5w-vv93-3f7w"}],"prev":{"headline":"Apache Thrift Node.js static web server sandbox escape","id":"CVE-2018-11798"},"products":["Apache Oozie"],"published":"2018-12-19","related":[{"cvss_score":6.5,"headline":"Path Traversal in Apache Oozie","id":"CVE-2017-15712","kev_date_added":null,"published":"2018-02-19"},{"cvss_score":5.4,"headline":"Apache Oozie: XSS in Oozie Web Console","id":"CVE-2025-26796","kev_date_added":null,"published":"2025-03-22"},{"cvss_score":4.7,"headline":"Oozie local privilege escalation","id":"CVE-2020-35451","kev_date_added":null,"published":"2021-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Apache Software Foundation"]},"summary":"A malicious user can impersonate other users by crafting specific XML, allowing workflows to run under other users' identities.","url":"https://insights.sbomify.com/CVE-2018-11799/"}