# CVE-2018-11799: Moderate severity vulnerability that affects org.apache.oozie:oozie-core

> A malicious user can impersonate other users by crafting specific XML, allowing workflows to run under other users' identities.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wg5w-vv93-3f7w

## What is CVE-2018-11799?

CVE-2018-11799 is a medium-severity authentication bypass vulnerability in Apache Oozie, published on 19 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Vulnerability allows a user of Apache Oozie 3.1.3-incubating to 5.0.0 to impersonate other users. The malicious user can construct an XML that results workflows running in other user's name.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-11799?

2 open source packages ship an affected version, including org.apache.oozie:oozie-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.oozie:oozie-core` | Maven | All versions | 5.1.0 |
| `org.apache.oozie:oozie-core` | Maven | All versions | 5.1.0 |

Products: Apache Oozie.

## How do I fix CVE-2018-11799?

Upgrade org.apache.oozie:oozie-core to 5.1.0 or later.

## Is CVE-2018-11799 being exploited?

There is no known exploitation of CVE-2018-11799 in the wild and no public exploit code.

## Other vulnerabilities in Apache Oozie

- [CVE-2017-15712](https://insights.sbomify.com/CVE-2017-15712/): Path Traversal in Apache Oozie (medium 6.5)
- [CVE-2025-26796](https://insights.sbomify.com/CVE-2025-26796/): Apache Oozie: XSS in Oozie Web Console (medium 5.4)
- [CVE-2020-35451](https://insights.sbomify.com/CVE-2020-35451/): Oozie local privilege escalation (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11799 and fix it if it is affected.

What it is: CVE-2018-11799 is a medium-severity authentication bypass vulnerability in Apache Oozie, published on 19 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11799 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.oozie:oozie-core (Maven): affected all versions; fixed in 5.1.0
- org.apache.oozie:oozie-core (Maven): affected all versions; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11799/ (Markdown: https://insights.sbomify.com/CVE-2018-11799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11799
- OSV: https://osv.dev/vulnerability/CVE-2018-11799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11799/
Summaries are generated and may contain mistakes; the official description above is the record.
