# CVE-2018-11802: Incorrect Authorization in Apache Solr

> Attackers can bypass authorization checks in Apache Solr by sending requests for unhosted collections, allowing unauthorized access to data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-j346-h5wc-rw2m, UBUNTU-CVE-2018-11802

## What is CVE-2018-11802?

CVE-2018-11802 is a medium-severity missing authorization vulnerability in Apache Solr, published on 1 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Apache Solr, the cluster can be partitioned into multiple collections and only a subset of nodes actually host any given collection. However, if a node receives a request for a collection it does not host, it proxies the request to a relevant node and serves the request. Solr bypasses all authorization settings for such requests. This affects all Solr versions prior to 7.7 that use the default authorization mechanism of Solr (RuleBasedAuthorizationPlugin).

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-11802?

8 open source packages ship an affected version, including org.apache.solr:solr-core and org.apache.solr:solr-parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-core` | Maven | All versions | 6.6.6 |
| `org.apache.solr:solr-core` | Maven | All versions | 6.6.6 |
| `org.apache.solr:solr-core` | Maven | From 7.0.0 | 7.7.0 |
| `org.apache.solr:solr-core` | Maven | From 7.0.0 | 7.7.0 |
| `org.apache.solr:solr-parent` | Maven | All versions | 6.6.6 |
| `org.apache.solr:solr-parent` | Maven | All versions | 6.6.6 |
| `org.apache.solr:solr-parent` | Maven | From 7.0.0 | 7.7.0 |
| `org.apache.solr:solr-parent` | Maven | From 7.0.0 | 7.7.0 |

Products: Apache Solr.

## How do I fix CVE-2018-11802?

Upgrade org.apache.solr:solr-core to a fixed version for your release line: 6.6.6 or 7.7.0.

## Is CVE-2018-11802 being exploited?

There is no known exploitation of CVE-2018-11802 in the wild and no public exploit code.

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2021-27905](https://insights.sbomify.com/CVE-2021-27905/): SSRF vulnerability with the Replication handler (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11802 and fix it if it is affected.

What it is: CVE-2018-11802 is a medium-severity missing authorization vulnerability in Apache Solr, published on 1 Apr 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11802 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 6.6.6
- org.apache.solr:solr-core (Maven): affected all versions; fixed in 6.6.6
- org.apache.solr:solr-core (Maven): affected from 7.0.0; fixed in 7.7.0
- org.apache.solr:solr-core (Maven): affected from 7.0.0; fixed in 7.7.0
- org.apache.solr:solr-parent (Maven): affected all versions; fixed in 6.6.6
- org.apache.solr:solr-parent (Maven): affected all versions; fixed in 6.6.6
- org.apache.solr:solr-parent (Maven): affected from 7.0.0; fixed in 7.7.0
- org.apache.solr:solr-parent (Maven): affected from 7.0.0; fixed in 7.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11802/ (Markdown: https://insights.sbomify.com/CVE-2018-11802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11802
- OSV: https://osv.dev/vulnerability/CVE-2018-11802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11802/
Summaries are generated and may contain mistakes; the official description above is the record.
