{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-11803 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-11803 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 5 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-11803 and fix it if it is affected.\n\nWhat it is: CVE-2018-11803 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 5 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-11803 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11803/ (Markdown: https://insights.sbomify.com/CVE-2018-11803/index.md)","id":"CVE-2018-11803","markdown":"https://insights.sbomify.com/CVE-2018-11803/index.md","name":"CVE-2018-11803","record":{"aliases":["ALPINE-CVE-2018-11803","DEBIAN-CVE-2018-11803","GHSA-q2m4-jgq9-q8vh","SUSE-SU-2019:0195-1","openSUSE-SU-2019:0153-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Subversion module","requires_auth":"none","summary":"An attacker can cause a denial of service by triggering a crash in the Apache Subversion mod_dav_svn module via a malformed recursive directory listing request.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"subversion","vendor":"apache"},{"product":"ubuntu_linux","vendor":"canonical"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-824","name":"Access of Uninitialized Pointer"}],"description":"Subversion's mod_dav_svn Apache HTTPD module versions 1.11.0 and 1.10.0 to 1.10.3 will crash after dereferencing an uninitialized pointer if the client omits the root path in a recursive directory listing operation.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15","SUSE:Linux Enterprise Module for Development Tools 15","SUSE:Linux Enterprise Module for Server Applications 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Null dereference in Apache Subversion","id":"CVE-2018-11803","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux"],"type":"null_dereference","year":"2018"},"n_packages":4,"n_references":4,"next":{"headline":"Improper Input Validation in Apache Spark","id":"CVE-2018-11804"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["1.10.0-3.3.1"],"introduced":["0"],"last_affected":[],"package":"subversion","purl":"pkg:rpm/suse/subversion\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2019:0195-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Development Tools 15","fixed":["1.10.0-3.3.1"],"introduced":["0"],"last_affected":[],"package":"subversion","purl":"pkg:rpm/suse/subversion\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Development%20Tools%2015","source":"SUSE-SU-2019:0195-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Server Applications 15","fixed":["1.10.0-3.3.1"],"introduced":["0"],"last_affected":[],"package":"subversion","purl":"pkg:rpm/suse/subversion\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Server%20Applications%2015","source":"SUSE-SU-2019:0195-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["1.10.0-lp150.2.3.1"],"introduced":["0"],"last_affected":[],"package":"subversion","purl":"pkg:rpm/opensuse/subversion\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:0153-1"}],"prev":{"headline":"Incorrect Authorization in Apache Solr","id":"CVE-2018-11802"},"products":["Apache Subversion"],"published":"2019-02-05","related":[{"cvss_score":9.8,"headline":"A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha","id":"CVE-2017-9800","kev_date_added":null,"published":"2017-08-11"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2013-4246","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":8.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5259","kev_date_added":null,"published":"2016-01-08"},{"cvss_score":8.2,"headline":"Apache Subversion: Command line argument injection on Windows platforms","id":"CVE-2024-45720","kev_date_added":null,"published":"2024-10-09"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2015-0202","kev_date_added":null,"published":"2015-04-08"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2013-2112","kev_date_added":null,"published":"2013-07-31"},{"cvss_score":7.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5343","kev_date_added":null,"published":"2016-04-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"An attacker can cause a denial of service by triggering a crash in the Apache Subversion mod_dav_svn module via a malformed recursive directory listing request.","url":"https://insights.sbomify.com/CVE-2018-11803/"}