{"answers":{"affected":"2 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-1190 in the wild and no public exploit code.","fix":"Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to 3.20.2 or later.","what":"CVE-2018-1190 is a medium-severity cross-site scripting vulnerability in Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0, published on 4 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1190 and fix it if it is affected.\n\nWhat it is: CVE-2018-1190 is a medium-severity cross-site scripting vulnerability in Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0, published on 4 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1190 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.20.2\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 3.0.0; fixed in 3.20.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1190/ (Markdown: https://insights.sbomify.com/CVE-2018-1190/index.md)","id":"CVE-2018-1190","markdown":"https://insights.sbomify.com/CVE-2018-1190/index.md","name":"CVE-2018-1190","record":{"aliases":["GHSA-j97q-9xp9-g5fx"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Pivotal Cloud Foundry UAA","requires_auth":"none","summary":"Cross-site scripting in the UAA OpenID Connect check session iframe allows attackers to execute scripts in user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dell","cpe":[{"product":"cf-release","vendor":"cloudfoundry"},{"product":"uaa","vendor":"pivotal"},{"product":"uaa_bosh","vendor":"pivotal"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in these Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0. A cross-site scripting (XSS) attack is possible in the clientId parameter of a request to the UAA OpenID Connect check session iframe endpoint used for single logout session management.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pivotal Cloud Foundry UAA XSS on UAA OpenID Connect check session iframe endpoint","id":"CVE-2018-1190","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in Garden-runC","id":"CVE-2018-1191"},"packages":[{"ecosystem":"Maven","fixed":["3.20.2"],"introduced":["3.0.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-j97q-9xp9-g5fx"},{"ecosystem":"Maven","fixed":["3.20.2"],"introduced":["3.0.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-j97q-9xp9-g5fx"}],"prev":{"headline":"Cross-site scripting in Isilon OneFS","id":"CVE-2018-1189"},"products":["Pivotal Cloud Foundry products: all versions prior to cf-release v270, UAA v3.x prior to v3.20.2, and UAA bosh v30.x versions prior to v30.8 and all other versions prior to v45.0"],"published":"2018-01-04","related":[{"cvss_score":9.8,"headline":"Cloud Foundry Runtime Insufficient Session Expiration vulnerability","id":"CVE-2015-5171","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":9.8,"headline":"Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password","id":"CVE-2015-5172","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":9.8,"headline":"Auth bypass in Cloud Foundry","id":"CVE-2016-8218","kev_date_added":null,"published":"2017-06-13"},{"cvss_score":9.8,"headline":"Cloud Foundry UAA privilege escalation with user invitations","id":"CVE-2017-4992","kev_date_added":null,"published":"2017-06-13"},{"cvss_score":9.6,"headline":"Information disclosure in n/a","id":"CVE-2016-6658","kev_date_added":null,"published":"2018-03-29"},{"cvss_score":8.8,"headline":"Cloud Foundry Runtime Cross-Site Request Forgery vulnerability","id":"CVE-2015-5170","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2015-5173","kev_date_added":null,"published":"2017-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting in the UAA OpenID Connect check session iframe allows attackers to execute scripts in user sessions.","url":"https://insights.sbomify.com/CVE-2018-1190/"}