CVE-2018-1192 Cloud Foundry UAA SessionID present in Audit Event Logs
Attackers can steal session IDs from audit logs to impersonate logged-in users in Cloud Foundry UAA deployments.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1192?
CVE-2018-1192 is a high-severity vulnerability in Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, published on 1 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, the SessionID is logged in audit event logs. An attacker can use the SessionID to impersonate a logged-in user.
Weakness: CWE-200
Which versions are affected by CVE-2018-1192?
6 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 4.5.5 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 4.5.5 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.6.0 | 4.7.4 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.6.0 | 4.7.4 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.8.0 | 4.8.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.8.0 | 4.8.3 |
Products include Pivotal Software Cloud Foundry Cf-Deployment, Pivotal Software Cloud Foundry Cf-Release, Pivotal Software Cloud Foundry Uaa, Pivotal Software Cloud Foundry Uaa-Release.
How do I fix CVE-2018-1192?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 4.5.5, 4.7.4 or 4.8.3.
Is CVE-2018-1192 being exploited?
There is no known exploitation of CVE-2018-1192 in the wild and no public exploit code.
Sources
Also known as GHSA-xg5v-696h-c3vr.