{"answers":{"affected":"6 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 4 products.","exploited":"There is no known exploitation of CVE-2018-1192 in the wild and no public exploit code.","fix":"Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 4.5.5, 4.7.4 or 4.8.3.","what":"CVE-2018-1192 is a high-severity vulnerability in Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, published on 1 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1192 and fix it if it is affected.\n\nWhat it is: CVE-2018-1192 is a high-severity vulnerability in Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, published on 1 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1192 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 4.5.5\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 4.5.5\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.6.0; fixed in 4.7.4\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.6.0; fixed in 4.7.4\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.8.0; fixed in 4.8.3\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.8.0; fixed in 4.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1192/ (Markdown: https://insights.sbomify.com/CVE-2018-1192/index.md)","id":"CVE-2018-1192","markdown":"https://insights.sbomify.com/CVE-2018-1192/index.md","name":"CVE-2018-1192","record":{"aliases":["GHSA-xg5v-696h-c3vr"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloud Foundry UAA","requires_auth":"low_privilege","summary":"Attackers can steal session IDs from audit logs to impersonate logged-in users in Cloud Foundry UAA deployments.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dell","cpe":[{"product":"cloud_foundry_cf-deployment","vendor":"pivotal_software"},{"product":"cloud_foundry_cf-release","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa-release","vendor":"pivotal_software"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"In Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, the SessionID is logged in audit event logs. An attacker can use the SessionID to impersonate a logged-in user.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloud Foundry UAA SessionID present in Audit Event Logs","id":"CVE-2018-1192","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":6,"n_references":1,"next":{"headline":"Security feature bypass in Cloud Foundry Router","id":"CVE-2018-1193"},"packages":[{"ecosystem":"Maven","fixed":["4.5.5"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-xg5v-696h-c3vr"},{"ecosystem":"Maven","fixed":["4.5.5"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-xg5v-696h-c3vr"},{"ecosystem":"Maven","fixed":["4.7.4"],"introduced":["4.6.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-xg5v-696h-c3vr"},{"ecosystem":"Maven","fixed":["4.7.4"],"introduced":["4.6.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-xg5v-696h-c3vr"},{"ecosystem":"Maven","fixed":["4.8.3"],"introduced":["4.8.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-xg5v-696h-c3vr"},{"ecosystem":"Maven","fixed":["4.8.3"],"introduced":["4.8.0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-xg5v-696h-c3vr"}],"prev":{"headline":"Information disclosure in Garden-runC","id":"CVE-2018-1191"},"products":["Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3"],"published":"2018-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can steal session IDs from audit logs to impersonate logged-in users in Cloud Foundry UAA deployments.","url":"https://insights.sbomify.com/CVE-2018-1192/"}