# CVE-2018-1196: Moderate severity vulnerability that affects org.springframework.boot:spring-boot

> A symlink attack in the Spring Boot embedded launch script allows a local user to overwrite arbitrary files and escalate privileges.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xx65-cc7g-9pfp

## What is CVE-2018-1196?

CVE-2018-1196 is a medium-severity path traversal vulnerability in Dell EMC Spring Boot, published on 19 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Boot supports an embedded launch script that can be used to easily run the application as a systemd or init.d linux service. The script included with Spring Boot 1.5.9 and earlier and 2.0.0.M1 through 2.0.0.M7 is susceptible to a symlink attack which allows the "run_user" to overwrite and take ownership of any file on the same system. In order to instigate the attack, the application must be installed as a service and the "run_user" requires shell access to the server. Spring Boot application that are not installed as a service, or are not using the embedded launch script are not susceptible.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2018-1196?

2 open source packages ship an affected version, including org.springframework.boot:spring-boot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.boot:spring-boot` | Maven | From 1.5.0 | 1.5.10 |
| `org.springframework.boot:spring-boot` | Maven | From 1.5.0 | 1.5.10 |

Products: Vmware Spring Boot.

## How do I fix CVE-2018-1196?

Upgrade org.springframework.boot:spring-boot to 1.5.10 or later.

## Is CVE-2018-1196 being exploited?

There is no known exploitation of CVE-2018-1196 in the wild and no public exploit code.

## Other vulnerabilities in Dell EMC Spring Boot

- [CVE-2023-20873](https://insights.sbomify.com/CVE-2023-20873/): Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry (critical 9.8)
- [CVE-2026-40976](https://insights.sbomify.com/CVE-2026-40976/): Spring Boot's default security filter chain has no authorization rule with Actuator but without Health (critical 9.1)
- [CVE-2026-22731](https://insights.sbomify.com/CVE-2026-22731/): Authentication Bypass under Actuator Health groups paths (high 8.2)
- [CVE-2026-22733](https://insights.sbomify.com/CVE-2026-22733/): Authentication Bypass under Actuator CloudFoundry endpoints (high 8.2)
- [CVE-2022-27772](https://insights.sbomify.com/CVE-2022-27772/): Temporary Directory Hijacking to Local Privilege Escalation Vulnerability in org.springframework.boot:spring-boot (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1196 and fix it if it is affected.

What it is: CVE-2018-1196 is a medium-severity path traversal vulnerability in Dell EMC Spring Boot, published on 19 Mar 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1196 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.boot:spring-boot (Maven): affected from 1.5.0; fixed in 1.5.10
- org.springframework.boot:spring-boot (Maven): affected from 1.5.0; fixed in 1.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1196/ (Markdown: https://insights.sbomify.com/CVE-2018-1196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1196
- OSV: https://osv.dev/vulnerability/CVE-2018-1196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1196/
Summaries are generated and may contain mistakes; the official description above is the record.
