CVE-2018-12021 Singularity Incorrect Access Control
A malicious user can access sensitive information in Singularity containers using the overlay option on systems supporting overlay file systems.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-12021?
CVE-2018-12021 is a medium-severity vulnerability in n/a, published on 5 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Singularity 2.3.0 through 2.5.1 is affected by an incorrect access control on systems supporting overlay file system. When using the overlay option, a malicious user may access sensitive information by exploiting a few specific Singularity features.
Weakness: CWE-200
Which versions are affected by CVE-2018-12021?
2 open source packages ship an affected version, including github.com/hpcng/singularity. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hpcng/singularity Go | From 2.3.0 | 2.5.2 |
github.com/hpcng/singularity Go | From 2.3.0 | 2.5.2 |
Linux distribution packages (1)
singularity SUSE:Package Hub 12 SP3 | All versions | 2.3.2-11.1 |
Products include Sylabs Singularity.
How do I fix CVE-2018-12021?
Upgrade github.com/hpcng/singularity to 2.5.2 or later.
Is CVE-2018-12021 being exploited?
There is no known exploitation of CVE-2018-12021 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-4x32-h296-rg6j, UBUNTU-CVE-2018-12021, openSUSE-SU-2018:1969-1.