CVE-2018-12022 jackson-databind Deserialization of Untrusted Data vulnerability
Attackers can execute arbitrary code via malicious LDAP payloads if Default Typing is enabled and Jodd-db is present.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-12022?
CVE-2018-12022 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 17 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An issue was discovered in FasterXML jackson-databind prior to 2.7.9.4, 2.8.11.2, and 2.9.6. When Default Typing is enabled (either globally or for a specific property), the service has the Jodd-db jar (for database access for the Jodd framework) in the classpath, and an attacker can provide an LDAP service to access, it is possible to make the service execute a malicious payload.
Weakness: CWE-502
Which versions are affected by CVE-2018-12022?
6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 11 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.7.9.4 |
com.fasterxml.jackson.core:jackson-databind Maven | All versions | 2.7.9.4 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.2 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.2 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.6 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.6 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Fedoraproject Fedora, Oracle Jd Edwards Enterpriseone Tools, Oracle Retail Merchandising System, Redhat Automation Manager and 5 more.
How do I fix CVE-2018-12022?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.4, 2.8.11.2 or 2.9.6.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2018-12022 being exploited?
There is no known exploitation of CVE-2018-12022 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-WP47041, DEBIAN-CVE-2018-12022, GHSA-cjjf-94ff-43w7, ROOT-APP-MAVEN-CVE-2018-12022, UBUNTU-CVE-2018-12022.