{"answers":{"affected":"2 open source packages ship an affected version, including passenger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-12027 in the wild and no public exploit code.","fix":"Upgrade passenger to 5.3.2 or later.","what":"CVE-2018-12027 is a high-severity vulnerability in n/a, published on 17 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12027 and fix it if it is affected.\n\nWhat it is: CVE-2018-12027 is a high-severity vulnerability in n/a, published on 17 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12027 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passenger (RubyGems): affected from 5.3.0; fixed in 5.3.2\n- passenger (RubyGems): affected from 5.3.0; fixed in 5.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12027/ (Markdown: https://insights.sbomify.com/CVE-2018-12027/index.md)","id":"CVE-2018-12027","markdown":"https://insights.sbomify.com/CVE-2018-12027/index.md","name":"CVE-2018-12027","record":{"aliases":["GHSA-whfx-877c-5p28"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Phusion Passenger","requires_auth":"low_privilege","summary":"A local attacker can redirect application traffic by exploiting insecure Unix socket directory permissions, leading to information disclosure.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"passenger","vendor":"phusion"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"An Insecure Permissions vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 causes information disclosure in the following situation: given a Passenger-spawned application process that reports that it listens on a certain Unix domain socket, if any of the parent directories of said socket are writable by a normal user that is not the application's user, then that non-application user can swap that directory with something else, resulting in traffic being redirected to a non-application user's process through an alternative Unix domain socket.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure Permissions in Phusion Passenger","id":"CVE-2018-12027","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Incorrect Access Control in Phusion Passenger","id":"CVE-2018-12028"},"packages":[{"ecosystem":"RubyGems","fixed":["5.3.2"],"introduced":["5.3.0"],"last_affected":[],"package":"passenger","purl":null,"source":"GHSA-whfx-877c-5p28"},{"ecosystem":"RubyGems","fixed":["5.3.2"],"introduced":["5.3.0"],"last_affected":[],"package":"passenger","purl":"pkg:gem/passenger","source":"GHSA-whfx-877c-5p28"}],"prev":{"headline":"Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability","id":"CVE-2018-12026"},"products":["n/a"],"published":"2018-06-17","related":[{"cvss_score":9.8,"headline":"Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability","id":"CVE-2018-12026","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Incorrect Access Control in Phusion Passenger","id":"CVE-2018-12028","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Phusion Passenger uses a known /tmp filename","id":"CVE-2016-10345","kev_date_added":null,"published":"2017-04-18"},{"cvss_score":7.5,"headline":"RubyGems passenger gem allows remote attackers to delete files","id":"CVE-2012-6135","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":5.3,"headline":"Phusion Passenger denial of service","id":"CVE-2025-26803","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":5.3,"headline":"Phusion Passenger incorrect permission assignment","id":"CVE-2018-12615","kev_date_added":null,"published":"2018-06-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A local attacker can redirect application traffic by exploiting insecure Unix socket directory permissions, leading to information disclosure.","url":"https://insights.sbomify.com/CVE-2018-12027/"}