# CVE-2018-12027: Insecure Permissions in Phusion Passenger

> A local attacker can redirect application traffic by exploiting insecure Unix socket directory permissions, leading to information disclosure.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-whfx-877c-5p28

## What is CVE-2018-12027?

CVE-2018-12027 is a high-severity vulnerability in n/a, published on 17 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An Insecure Permissions vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 causes information disclosure in the following situation: given a Passenger-spawned application process that reports that it listens on a certain Unix domain socket, if any of the parent directories of said socket are writable by a normal user that is not the application's user, then that non-application user can swap that directory with something else, resulting in traffic being redirected to a non-application user's process through an alternative Unix domain socket.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-12027?

2 open source packages ship an affected version, including passenger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | From 5.3.0 | 5.3.2 |
| `passenger` | RubyGems | From 5.3.0 | 5.3.2 |

Products: Phusion Passenger.

## How do I fix CVE-2018-12027?

Upgrade passenger to 5.3.2 or later.

## Is CVE-2018-12027 being exploited?

There is no known exploitation of CVE-2018-12027 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-12026](https://insights.sbomify.com/CVE-2018-12026/): Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability (critical 9.8)
- [CVE-2018-12028](https://insights.sbomify.com/CVE-2018-12028/): Incorrect Access Control in Phusion Passenger (high 7.8)
- [CVE-2016-10345](https://insights.sbomify.com/CVE-2016-10345/): Phusion Passenger uses a known /tmp filename (high 7.8)
- [CVE-2012-6135](https://insights.sbomify.com/CVE-2012-6135/): RubyGems passenger gem allows remote attackers to delete files (high 7.5)
- [CVE-2025-26803](https://insights.sbomify.com/CVE-2025-26803/): Phusion Passenger denial of service (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12027 and fix it if it is affected.

What it is: CVE-2018-12027 is a high-severity vulnerability in n/a, published on 17 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-12027 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected from 5.3.0; fixed in 5.3.2
- passenger (RubyGems): affected from 5.3.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12027/ (Markdown: https://insights.sbomify.com/CVE-2018-12027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12027
- OSV: https://osv.dev/vulnerability/CVE-2018-12027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12027/
Summaries are generated and may contain mistakes; the official description above is the record.
