# CVE-2018-12028: Incorrect Access Control in Phusion Passenger

> A malicious application can trick Passenger into killing arbitrary processes, causing denial of service on the host system.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-jjhj-8gx7-x836

## What is CVE-2018-12028?

CVE-2018-12028 is a high-severity missing authorization vulnerability in n/a, published on 17 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An Incorrect Access Control vulnerability in SpawningKit in Phusion Passenger 5.3.x before 5.3.2 allows a Passenger-managed malicious application, upon spawning a child process, to report an arbitrary different PID back to Passenger's process manager. If the malicious application then generates an error, it would cause Passenger's process manager to kill said reported arbitrary PID.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-12028?

2 open source packages ship an affected version, including passenger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | From 5.3.0 | 5.3.2 |
| `passenger` | RubyGems | From 5.3.0 | 5.3.2 |

Products: Phusion Passenger.

## How do I fix CVE-2018-12028?

Upgrade passenger to 5.3.2 or later.

## Is CVE-2018-12028 being exploited?

There is no known exploitation of CVE-2018-12028 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-12026](https://insights.sbomify.com/CVE-2018-12026/): Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability (critical 9.8)
- [CVE-2018-12027](https://insights.sbomify.com/CVE-2018-12027/): Insecure Permissions in Phusion Passenger (high 8.8)
- [CVE-2016-10345](https://insights.sbomify.com/CVE-2016-10345/): Phusion Passenger uses a known /tmp filename (high 7.8)
- [CVE-2012-6135](https://insights.sbomify.com/CVE-2012-6135/): RubyGems passenger gem allows remote attackers to delete files (high 7.5)
- [CVE-2025-26803](https://insights.sbomify.com/CVE-2025-26803/): Phusion Passenger denial of service (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12028 and fix it if it is affected.

What it is: CVE-2018-12028 is a high-severity missing authorization vulnerability in n/a, published on 17 Jun 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-12028 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected from 5.3.0; fixed in 5.3.2
- passenger (RubyGems): affected from 5.3.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12028/ (Markdown: https://insights.sbomify.com/CVE-2018-12028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12028
- OSV: https://osv.dev/vulnerability/CVE-2018-12028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12028/
Summaries are generated and may contain mistakes; the official description above is the record.
