{"answers":{"affected":"2 open source packages ship an affected version, including passenger. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-12029 in the wild and no public exploit code.","fix":"Upgrade passenger to 5.3.2 or later.","what":"CVE-2018-12029 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12029 and fix it if it is affected.\n\nWhat it is: CVE-2018-12029 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12029 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passenger (RubyGems): affected from 3.0.0; fixed in 5.3.2\n- passenger (RubyGems): affected from 3.0.0; fixed in 5.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12029/ (Markdown: https://insights.sbomify.com/CVE-2018-12029/index.md)","id":"CVE-2018-12029","markdown":"https://insights.sbomify.com/CVE-2018-12029/index.md","name":"CVE-2018-12029","record":{"aliases":["DEBIAN-CVE-2018-12029","GHSA-jjcj-fgfm-9g9r","SUSE-SU-2018:2039-1","UBUNTU-CVE-2018-12029"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Phusion Passenger","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges via a race condition in Phusion Passenger when using a non-standard instance registry directory with weak permissions.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"passenger","vendor":"phusion"}],"cvss":{"score":7,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passenger_instance_registry_dir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.","ecosystems":["RubyGems","SUSE:Linux Enterprise Module for Containers 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Phusion Passenger Race Condition Allows Privilege Escalation","id":"CVE-2018-12029","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"race_condition","year":"2018"},"n_packages":3,"n_references":4,"next":{"headline":"Chevereto Free before 1.0.13 has XSS.","id":"CVE-2018-12030"},"packages":[{"ecosystem":"RubyGems","fixed":["5.3.2"],"introduced":["3.0.0"],"last_affected":[],"package":"passenger","purl":null,"source":"GHSA-jjcj-fgfm-9g9r"},{"ecosystem":"RubyGems","fixed":["5.3.2"],"introduced":["3.0.0"],"last_affected":[],"package":"passenger","purl":"pkg:gem/passenger","source":"GHSA-jjcj-fgfm-9g9r"},{"ecosystem":"SUSE:Linux Enterprise Module for Containers 12","fixed":["5.0.18-12.9.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-passenger","purl":"pkg:rpm/suse/rubygem-passenger\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Containers%2012","source":"SUSE-SU-2018:2039-1"}],"prev":{"headline":"Incorrect Access Control in Phusion Passenger","id":"CVE-2018-12028"},"products":["n/a"],"published":"2018-06-17","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Local attackers can escalate privileges via a race condition in Phusion Passenger when using a non-standard instance registry directory with weak permissions.","url":"https://insights.sbomify.com/CVE-2018-12029/"}