# CVE-2018-12029: Phusion Passenger Race Condition Allows Privilege Escalation

> Local attackers can escalate privileges via a race condition in Phusion Passenger when using a non-standard instance registry directory with weak permissions.

- **Severity:** High 7.0 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-12029, GHSA-jjcj-fgfm-9g9r, SUSE-SU-2018:2039-1, UBUNTU-CVE-2018-12029

## What is CVE-2018-12029?

CVE-2018-12029 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passenger_instance_registry_dir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2018-12029?

2 open source packages ship an affected version, including passenger. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | From 3.0.0 | 5.3.2 |
| `passenger` | RubyGems | From 3.0.0 | 5.3.2 |
| `rubygem-passenger` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 5.0.18-12.9.1 |

Products: Debian Debian Linux, Phusion Passenger.

## How do I fix CVE-2018-12029?

Upgrade passenger to 5.3.2 or later.

## Is CVE-2018-12029 being exploited?

There is no known exploitation of CVE-2018-12029 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12029 and fix it if it is affected.

What it is: CVE-2018-12029 is a high-severity vulnerability in Debian Debian Linux, published on 17 Jun 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-12029 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected from 3.0.0; fixed in 5.3.2
- passenger (RubyGems): affected from 3.0.0; fixed in 5.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12029/ (Markdown: https://insights.sbomify.com/CVE-2018-12029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12029
- OSV: https://osv.dev/vulnerability/CVE-2018-12029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12029/
Summaries are generated and may contain mistakes; the official description above is the record.
