# CVE-2018-12071: CodeIgniter Session Fixation Vulnerability

> Attackers can hijack user sessions in CodeIgniter applications due to improper session fixation protection, leading to account takeover.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2018
- **Updated:** 9 Jun 2025
- **Also known as:** GHSA-g434-3q2j-hj4r

## What is CVE-2018-12071?

CVE-2018-12071 is a critical authentication bypass vulnerability in n/a, published on 17 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2018-12071?

2 open source packages ship an affected version, including codeigniter/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter/framework` | Packagist | All versions | 3.1.10 |
| `codeigniter/framework` | Packagist | All versions | 3.1.10 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2018-12071?

Upgrade codeigniter/framework to 3.1.10 or later.

## Is CVE-2018-12071 being exploited?

There is no known exploitation of CVE-2018-12071 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12071 and fix it if it is affected.

What it is: CVE-2018-12071 is a critical authentication bypass vulnerability in n/a, published on 17 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-12071 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter/framework (Packagist): affected all versions; fixed in 3.1.10
- codeigniter/framework (Packagist): affected all versions; fixed in 3.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12071/ (Markdown: https://insights.sbomify.com/CVE-2018-12071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12071
- OSV: https://osv.dev/vulnerability/CVE-2018-12071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12071/
Summaries are generated and may contain mistakes; the official description above is the record.
