# CVE-2018-12086: High severity vulnerability that affects OPCFoundation.NetStandard.Opc.Ua

> Remote attackers can trigger a stack overflow via crafted requests, potentially leading to code execution or denial of service in OPC UA applications.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-12086, GHSA-782p-53wq-cxmj

## What is CVE-2018-12086?

CVE-2018-12086 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 14 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Buffer overflow in OPC UA applications allows remote attackers to trigger a stack overflow with carefully structured requests.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2018-12086?

2 open source packages ship an affected version, including OPCFoundation.NetStandard.Opc.Ua. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OPCFoundation.NetStandard.Opc.Ua` | NuGet | All versions | 1.4.353.15 |
| `OPCFoundation.NetStandard.Opc.Ua` | NuGet | All versions | 1.4.353.15 |

Products: Debian Debian Linux, Opcfoundation Unified Architecture-.Net-Legacy, Opcfoundation Unified Architecture-Java, Opcfoundation Unified Architecture .Net-Standard, Opcfoundation Unified Architecture Ansic.

## How do I fix CVE-2018-12086?

Upgrade OPCFoundation.NetStandard.Opc.Ua to 1.4.353.15 or later.

## Is CVE-2018-12086 being exploited?

There is no known exploitation of CVE-2018-12086 in the wild and no public exploit code.

Public exploit code:

- PoC for CVE-2018-12086 affecting various OPC UA stacks (github_poc): https://github.com/kevinherron/stack-overflow-poc

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12086 and fix it if it is affected.

What it is: CVE-2018-12086 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 14 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-12086 in the wild and no public exploit code.

Affected packages and fixed versions:
- OPCFoundation.NetStandard.Opc.Ua (NuGet): affected all versions; fixed in 1.4.353.15
- OPCFoundation.NetStandard.Opc.Ua (NuGet): affected all versions; fixed in 1.4.353.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12086/ (Markdown: https://insights.sbomify.com/CVE-2018-12086/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12086
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12086
- OSV: https://osv.dev/vulnerability/CVE-2018-12086

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12086/
Summaries are generated and may contain mistakes; the official description above is the record.
