{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-12115 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-12115 is a high-severity memory corruption vulnerability in Nodejs Node.js, published on 21 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12115 and fix it if it is affected.\n\nWhat it is: CVE-2018-12115 is a high-severity memory corruption vulnerability in Nodejs Node.js, published on 21 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12115 in the wild and no public exploit code.\n\nAffected product: Nodejs Node.js. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12115/ (Markdown: https://insights.sbomify.com/CVE-2018-12115/index.md)","id":"CVE-2018-12115","markdown":"https://insights.sbomify.com/CVE-2018-12115/index.md","name":"CVE-2018-12115","record":{"aliases":["ALPINE-CVE-2018-12115","CLEANSTART-2026-QB23308","CLEANSTART-2026-RX03118","DEBIAN-CVE-2018-12115","GHSA-q85m-543x-pwpc","RHSA-2018:2944","UBUNTU-CVE-2018-12115"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js runtime","requires_auth":"none","summary":"Buffer overflow in Node.js UCS-2 encoding allows attackers to write outside buffer bounds, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"nodejs","cpe":[{"product":"node.js","vendor":"nodejs"},{"product":"openshift_container_platform","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"}],"description":"In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.","ecosystems":["Red Hat:rhel_software_collections:3::el6","Red Hat:rhel_software_collections:3::el7"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in Node.js","id":"CVE-2018-12115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"nodejs:node.js","products":["nodejs:node.js","redhat:openshift_container_platform"],"type":"memory_corruption","year":"2018"},"n_packages":8,"n_references":8,"next":{"headline":"Other in Node.js","id":"CVE-2018-12116"},"packages":[{"ecosystem":"Red Hat:rhel_software_collections:3::el6","fixed":["0:6.11.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el6","fixed":["0:6.11.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-debuginfo","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-debuginfo","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el6","fixed":["0:6.11.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-devel","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-devel","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el6","fixed":["0:6.11.3-6.el6"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-docs","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-docs","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:6.11.3-7.el7"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:6.11.3-7.el7"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-debuginfo","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-debuginfo","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:6.11.3-7.el7"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-devel","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-devel","source":"RHSA-2018:2944"},{"ecosystem":"Red Hat:rhel_software_collections:3::el7","fixed":["0:6.11.3-7.el7"],"introduced":["0"],"last_affected":[],"package":"rh-nodejs6-nodejs-docs","purl":"pkg:rpm/redhat/rh-nodejs6-nodejs-docs","source":"RHSA-2018:2944"}],"prev":{"headline":"Cross-site request forgery in n/a","id":"CVE-2018-12114"},"products":["Node.js"],"published":"2018-08-21","related":[{"cvss_score":9.8,"headline":"Security feature bypass in Node","id":"CVE-2023-32002","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2016-6303","kev_date_added":null,"published":"2016-09-16"},{"cvss_score":9.1,"headline":"Security feature bypass in Node.js","id":"CVE-2017-15896","kev_date_added":null,"published":"2017-12-11"},{"cvss_score":8.8,"headline":"Server-side request forgery in Node.js","id":"CVE-2018-7160","kev_date_added":null,"published":"2018-05-17"},{"cvss_score":8.1,"headline":"Misconfiguration in Node.js","id":"CVE-2018-12120","kev_date_added":null,"published":"2018-11-28"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21891","kev_date_added":null,"published":"2024-02-20"},{"cvss_score":7.9,"headline":"Path traversal in Node","id":"CVE-2024-21896","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["The Node.js Project"]},"summary":"Buffer overflow in Node.js UCS-2 encoding allows attackers to write outside buffer bounds, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2018-12115/"}