# CVE-2018-12457: express-cart allows any user to create an admin user

> Remote attackers can create an admin user by manipulating the Referer header, leading to full administrative control of the expressCart application.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-hr89-w7p6-pjmq

## What is CVE-2018-12457?

CVE-2018-12457 is a high-severity missing authorization vulnerability in n/a, published on 15 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2018-12457?

2 open source packages ship an affected version, including express-cart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `express-cart` | npm | All versions | 1.1.6 |
| `express-cart` | npm | All versions | 1.1.6 |

Products: Expresscart Project Expresscart.

## How do I fix CVE-2018-12457?

Upgrade express-cart to 1.1.6 or later.

## Is CVE-2018-12457 being exploited?

There is no known exploitation of CVE-2018-12457 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12457 and fix it if it is affected.

What it is: CVE-2018-12457 is a high-severity missing authorization vulnerability in n/a, published on 15 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-12457 in the wild and no public exploit code.

Affected packages and fixed versions:
- express-cart (npm): affected all versions; fixed in 1.1.6
- express-cart (npm): affected all versions; fixed in 1.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12457/ (Markdown: https://insights.sbomify.com/CVE-2018-12457/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12457
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12457
- OSV: https://osv.dev/vulnerability/CVE-2018-12457

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12457/
Summaries are generated and may contain mistakes; the official description above is the record.
