# CVE-2018-12538: Access and integrity issue within Eclipse Jetty

> Attackers can hijack or delete other users' sessions when using the optional FileSessionDataStore in Eclipse Jetty.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mwcx-532g-8pq3

## What is CVE-2018-12538?

CVE-2018-12538 is a high-severity missing authorization vulnerability in Eclipse Jetty, published on 22 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Eclipse Jetty versions 9.4.0 through 9.4.8, when using the optional Jetty provided FileSessionDataStore for persistent storage of HttpSession details, it is possible for a malicious user to access/hijack other HttpSessions and even delete unmatched HttpSessions present in the FileSystem's storage for the FileSessionDataStore.

Weakness: CWE-384 (Session Fixation), CWE-6 (J2EE Misconfiguration: Insufficient Session-ID Length)

## Which versions are affected by CVE-2018-12538?

2 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 12 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.11.v20180605 |
| `org.eclipse.jetty:jetty-server` | Maven | From 9.4.0 | 9.4.11.v20180605 |

Products: Eclipse Jetty, Netapp E-Series Santricity Management Plug-Ins, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services Proxy, Netapp Element Software, Netapp Hyper Converged Infrastructure, Netapp Oncommand System Manager, Netapp Oncommand Unified Manager, Netapp Santricity Cloud Connector, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager.

## How do I fix CVE-2018-12538?

Upgrade org.eclipse.jetty:jetty-server to 9.4.11.v20180605 or later.

## Is CVE-2018-12538 being exploited?

There is no known exploitation of CVE-2018-12538 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)
- [CVE-2024-7708](https://insights.sbomify.com/CVE-2024-7708/): Eclipse Jetty: DoS attack triggering OutOfMemory with 100-Continue requests (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-12538 and fix it if it is affected.

What it is: CVE-2018-12538 is a high-severity missing authorization vulnerability in Eclipse Jetty, published on 22 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-12538 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.11.v20180605
- org.eclipse.jetty:jetty-server (Maven): affected from 9.4.0; fixed in 9.4.11.v20180605

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-12538/ (Markdown: https://insights.sbomify.com/CVE-2018-12538/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-12538
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-12538
- OSV: https://osv.dev/vulnerability/CVE-2018-12538

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-12538/
Summaries are generated and may contain mistakes; the official description above is the record.
