{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-12558 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-12558 is a high-severity denial of service vulnerability in n/a, published on 20 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12558 and fix it if it is affected.\n\nWhat it is: CVE-2018-12558 is a high-severity denial of service vulnerability in n/a, published on 20 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12558 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12558/ (Markdown: https://insights.sbomify.com/CVE-2018-12558/index.md)","id":"CVE-2018-12558","markdown":"https://insights.sbomify.com/CVE-2018-12558/index.md","name":"CVE-2018-12558","record":{"aliases":["ALPINE-CVE-2018-12558","DEBIAN-CVE-2018-12558","GHSA-c2fh-m553-m5hp","MGASA-2019-0046","UBUNTU-CVE-2018-12558","openSUSE-SU-2019:1114-1","openSUSE-SU-2024:12651-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl Email::Address module","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the Perl Email::Address module by providing specially crafted input with form-field characters.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"\\","vendor":"email\\"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"The parse() method in the Email::Address module through 1.909 for Perl is vulnerable to Algorithmic complexity on specially prepared input, leading to Denial of Service. Prepared special input that caused this problem contained 30 form-field characters (\"\\f\").","ecosystems":["SUSE:Package Hub 15","openSUSE:Leap 15.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-12558","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Path traversal in n/a","id":"CVE-2018-12559"},"packages":[{"ecosystem":"SUSE:Package Hub 15","fixed":["1.912-bp150.3.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Email-Address","purl":"pkg:rpm/suse/perl-Email-Address\u0026distro=SUSE%20Package%20Hub%2015","source":"openSUSE-SU-2019:1114-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["1.912-bp150.3.3.1"],"introduced":["0"],"last_affected":[],"package":"perl-Email-Address","purl":"pkg:rpm/opensuse/perl-Email-Address\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1114-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.913-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-Email-Address","purl":"pkg:rpm/opensuse/perl-Email-Address\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12651-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-12557"},"products":["n/a"],"published":"2018-06-20","related":[{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2014-4720","kev_date_added":null,"published":"2014-07-06"},{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2014-0477","kev_date_added":null,"published":"2014-07-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service in applications using the Perl Email::Address module by providing specially crafted input with form-field characters.","url":"https://insights.sbomify.com/CVE-2018-12558/"}