# CVE-2018-1256: Issuer validation regression in Spring Cloud SSO Connector

> Attackers can bypass authentication on unbound resource servers by using tokens from different SSO service plans in multi-plan PCF deployments.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-q4q2-93pw-qwgf

## What is CVE-2018-1256?

CVE-2018-1256 is a high-severity authentication bypass vulnerability in Pivotal Spring Cloud SSO Connector, published on 7 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Cloud SSO Connector, version 2.1.2, contains a regression which disables issuer validation in resource servers that are not bound to the SSO service. In PCF deployments with multiple SSO service plans, a remote attacker can authenticate to unbound resource servers which use this version of the SSO Connector with tokens generated from another service plan.

## Which versions are affected by CVE-2018-1256?

2 open source packages ship an affected version, including io.pivotal.spring.cloud:spring-cloud-sso-connector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.pivotal.spring.cloud:spring-cloud-sso-connector` | Maven | From 2.1.2.RELEASE | 2.1.3.RELEASE |
| `io.pivotal.spring.cloud:spring-cloud-sso-connector` | Maven | From 2.1.2.RELEASE | 2.1.3.RELEASE |

Products: Vmware Spring Cloud Sso Connector.

## How do I fix CVE-2018-1256?

Upgrade io.pivotal.spring.cloud:spring-cloud-sso-connector to 2.1.3.RELEASE or later.

## Is CVE-2018-1256 being exploited?

There is no known exploitation of CVE-2018-1256 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1256 and fix it if it is affected.

What it is: CVE-2018-1256 is a high-severity authentication bypass vulnerability in Pivotal Spring Cloud SSO Connector, published on 7 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1256 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.pivotal.spring.cloud:spring-cloud-sso-connector (Maven): affected from 2.1.2.RELEASE; fixed in 2.1.3.RELEASE
- io.pivotal.spring.cloud:spring-cloud-sso-connector (Maven): affected from 2.1.2.RELEASE; fixed in 2.1.3.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1256/ (Markdown: https://insights.sbomify.com/CVE-2018-1256/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1256
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1256
- OSV: https://osv.dev/vulnerability/CVE-2018-1256

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1256/
Summaries are generated and may contain mistakes; the official description above is the record.
