# CVE-2018-1257: Denial of Service in org.springframework:spring-core

> Attackers can cause denial of service in Spring Framework applications using STOMP over WebSocket with an in-memory broker via crafted messages.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2018
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2018-1257, GHSA-rcpf-vj53-7h2m, UBUNTU-CVE-2018-1257

## What is CVE-2018-1257?

CVE-2018-1257 is a medium-severity denial of service vulnerability in Oracle Agile Product Lifecycle Management, published on 11 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spring Framework, versions 5.0.x prior to 5.0.6, versions 4.3.x prior to 4.3.17, and older unsupported versions allows applications to expose STOMP over WebSocket endpoints with a simple, in-memory STOMP broker through the spring-messaging module. A malicious user (or attacker) can craft a message to the broker that can lead to a regular expression, denial of service attack.

## Which versions are affected by CVE-2018-1257?

4 open source packages ship an affected version, including org.springframework:spring-core. It affects 30 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | All versions | 4.3.17 |
| `org.springframework:spring-core` | Maven | All versions | 4.3.17 |
| `org.springframework:spring-core` | Maven | From 5.0.0 | 5.0.6 |
| `org.springframework:spring-core` | Maven | From 5.0.0 | 5.0.6 |

Products: Oracle Agile Product Lifecycle Management, Oracle Application Testing Suite, Oracle Big Data Discovery, Oracle Communications Converged Application Server, Oracle Communications Diameter Signaling Router, Oracle Communications Performance Intelligence Center, Oracle Communications Services Gatekeeper, Oracle Communications Unified Inventory Management, Oracle Endeca Information Discovery Integrator, Oracle Enterprise Manager Base Platform, Oracle Enterprise Manager for Mysql Database, Oracle Enterprise Manager Ops Center, Oracle Flexcube Private Banking, Oracle Goldengate for Big Data, Oracle Health Sciences Information Manager, Oracle Healthcare Master Person Index, Oracle Hospitality Guest Access, Oracle Insurance Calculation Engine, Oracle Insurance Rules Palette, Oracle Primavera Gateway and 10 more.

## How do I fix CVE-2018-1257?

Upgrade org.springframework:spring-core to a fixed version for your release line: 4.3.17 or 5.0.6.

## Is CVE-2018-1257 being exploited?

There is no known exploitation of CVE-2018-1257 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Agile Product Lifecycle Management

- [CVE-2024-20953](https://insights.sbomify.com/CVE-2024-20953/): Oracle Agile Product Lifecycle Management (PLM) Deserialization (high 8.8, exploited in the wild)
- [CVE-2024-21287](https://insights.sbomify.com/CVE-2024-21287/): Oracle Agile Product Lifecycle Management (PLM) Incorrect Authorization (high 7.5, exploited in the wild)
- [CVE-2019-2725](https://insights.sbomify.com/CVE-2019-2725/): Oracle WebLogic Server, Injection (high 7.5, exploited in the wild)
- [CVE-2025-21556](https://insights.sbomify.com/CVE-2025-21556/): Missing authorization in Oracle Agile PLM Framework (critical 9.9)
- [CVE-2026-71040](https://insights.sbomify.com/CVE-2026-71040/): Auth bypass in Oracle Agile PLM (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1257 and fix it if it is affected.

What it is: CVE-2018-1257 is a medium-severity denial of service vulnerability in Oracle Agile Product Lifecycle Management, published on 11 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1257 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected all versions; fixed in 4.3.17
- org.springframework:spring-core (Maven): affected all versions; fixed in 4.3.17
- org.springframework:spring-core (Maven): affected from 5.0.0; fixed in 5.0.6
- org.springframework:spring-core (Maven): affected from 5.0.0; fixed in 5.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1257/ (Markdown: https://insights.sbomify.com/CVE-2018-1257/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1257
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1257
- OSV: https://osv.dev/vulnerability/CVE-2018-1257

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1257/
Summaries are generated and may contain mistakes; the official description above is the record.
