# CVE-2018-1258: Spring Framework when used in combination with any versions of Spring Security contains an authorization bypass

> An authorization bypass in Spring Framework with Spring Security allows unauthorized users to access restricted methods.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-cxrj-66c5-9fmh

## What is CVE-2018-1258?

CVE-2018-1258 is a high-severity authentication bypass vulnerability in Netapp Oncommand Insight, published on 11 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spring Framework version 5.0.5 when used in combination with any versions of Spring Security contains an authorization bypass when using method security. An unauthorized malicious user can gain unauthorized access to methods that should be restricted.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2018-1258?

2 open source packages ship an affected version, including org.springframework:spring-core. It affects 42 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | From 5.0.5.RELEASE | 5.0.6.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.0.5.RELEASE | 5.0.6.RELEASE |

Products: Netapp Oncommand Insight, Netapp Oncommand Unified Manager, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Netapp Storage Automation Store, Oracle Agile Product Lifecycle Management, Oracle Application Testing Suite, Oracle Big Data Discovery, Oracle Communications Converged Application Server, Oracle Communications Diameter Signaling Router, Oracle Communications Network Integrity, Oracle Communications Performance Intelligence Center, Oracle Communications Services Gatekeeper, Oracle Endeca Information Discovery Integrator, Oracle Enterprise Manager for Mysql Database, Oracle Enterprise Manager Ops Center, Oracle Enterprise Repository, Oracle Goldengate for Big Data, Oracle Health Sciences Information Manager, Oracle Healthcare Master Person Index and 22 more.

## How do I fix CVE-2018-1258?

Upgrade org.springframework:spring-core to 5.0.6.RELEASE or later.

## Is CVE-2018-1258 being exploited?

There is no known exploitation of CVE-2018-1258 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Oncommand Insight

- [CVE-2017-5600](https://insights.sbomify.com/CVE-2017-5600/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-5421](https://insights.sbomify.com/CVE-2020-5421/): RFD Protection Bypass via jsessionid (high 8.7)
- [CVE-2022-38733](https://insights.sbomify.com/CVE-2022-38733/): Auth bypass in OnCommand Insight (high 8.6)
- [CVE-2023-22102](https://insights.sbomify.com/CVE-2023-22102/): MySQL Connectors takeover vulnerability (high 8.3)
- [CVE-2021-35583](https://insights.sbomify.com/CVE-2021-35583/): Denial of service in MySQL Server (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1258 and fix it if it is affected.

What it is: CVE-2018-1258 is a high-severity authentication bypass vulnerability in Netapp Oncommand Insight, published on 11 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1258 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected from 5.0.5.RELEASE; fixed in 5.0.6.RELEASE
- org.springframework:spring-core (Maven): affected from 5.0.5.RELEASE; fixed in 5.0.6.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1258/ (Markdown: https://insights.sbomify.com/CVE-2018-1258/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1258
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1258
- OSV: https://osv.dev/vulnerability/CVE-2018-1258

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1258/
Summaries are generated and may contain mistakes; the official description above is the record.
