# CVE-2018-1259: Spring Data Commons, used in combination with XMLBeam, contains a property binder vulnerability caused by improper restriction of XML external entity references

> An unauthenticated attacker can exploit an XML external entity vulnerability in Spring Data Commons to read arbitrary files from the server.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-m929-7fr6-cvjg

## What is CVE-2018-1259?

CVE-2018-1259 is a high-severity vulnerability in Pivotal Spring Data Commons, published on 11 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Data Commons, versions 1.13 prior to 1.13.12 and 2.0 prior to 2.0.7, used in combination with XMLBeam 1.4.14 or earlier versions, contains a property binder vulnerability caused by improper restriction of XML external entity references as underlying library XMLBeam does not restrict external reference expansion. An unauthenticated remote malicious user can supply specially crafted request parameters against Spring Data's projection-based request payload binding to access arbitrary files on the system.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-1259?

4 open source packages ship an affected version, including org.springframework.data:spring-data-commons. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.data:spring-data-commons` | Maven | From 1.13.0 | 1.13.12 |
| `org.springframework.data:spring-data-commons` | Maven | From 1.13.0 | 1.13.12 |
| `org.springframework.data:spring-data-commons` | Maven | From 2.0.0 | 2.0.7 |
| `org.springframework.data:spring-data-commons` | Maven | From 2.0.0 | 2.0.7 |

Products: Broadcom Spring Data Commons, Pivotal Software Spring Data Rest, Vmware Spring Data Rest, Xmlbeam Xmlbeam.

## How do I fix CVE-2018-1259?

Upgrade org.springframework.data:spring-data-commons to a fixed version for your release line: 1.13.12 or 2.0.7.

## Is CVE-2018-1259 being exploited?

There is no known exploitation of CVE-2018-1259 in the wild and no public exploit code.

Public exploit code:

- https://github.com/tafamace/CVE-2018-1259 (github_poc): https://github.com/tafamace/CVE-2018-1259

## Other vulnerabilities in Pivotal Spring Data Commons

- [CVE-2026-41695](https://insights.sbomify.com/CVE-2026-41695/): Denial of Service in Spring Data Commons Property Path Resolution (high 7.5)
- [CVE-2026-41716](https://insights.sbomify.com/CVE-2026-41716/): Spring Data web support unbounded negative-result cache keyed on attacker-supplied property names (high 7.5)
- [CVE-2018-1274](https://insights.sbomify.com/CVE-2018-1274/): Spring Data Commons contain a property path parser vulnerability caused by unlimited resource allocation (high 7.5)
- [CVE-2026-41711](https://insights.sbomify.com/CVE-2026-41711/): Potential Denial of Service through crafted Sort Parameters (medium 5.9)
- [CVE-2026-41721](https://insights.sbomify.com/CVE-2026-41721/): Spring Data Commons Denial of Service via Data Binding (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1259 and fix it if it is affected.

What it is: CVE-2018-1259 is a high-severity vulnerability in Pivotal Spring Data Commons, published on 11 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1259 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.data:spring-data-commons (Maven): affected from 1.13.0; fixed in 1.13.12
- org.springframework.data:spring-data-commons (Maven): affected from 1.13.0; fixed in 1.13.12
- org.springframework.data:spring-data-commons (Maven): affected from 2.0.0; fixed in 2.0.7
- org.springframework.data:spring-data-commons (Maven): affected from 2.0.0; fixed in 2.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1259/ (Markdown: https://insights.sbomify.com/CVE-2018-1259/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1259
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1259
- OSV: https://osv.dev/vulnerability/CVE-2018-1259

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1259/
Summaries are generated and may contain mistakes; the official description above is the record.
