CVE-2018-1260 Spring Security OAuth vulnerable to remote code execution (RCE)
Attackers can achieve remote code execution by crafting malicious authorization requests in Spring Security OAuth.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1260?
CVE-2018-1260 is a critical code injection vulnerability in Pivotal Spring Security OAuth, published on 11 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring Security OAuth, versions 2.3 prior to 2.3.3, 2.2 prior to 2.2.2, 2.1 prior to 2.1.2, 2.0 prior to 2.0.15 and older unsupported versions contains a remote code execution vulnerability. A malicious user or attacker can craft an authorization request to the authorization endpoint that can lead to remote code execution when the resource owner is forwarded to the approval endpoint.
Weakness: CWE-94
Which versions are affected by CVE-2018-1260?
10 open source packages ship an affected version, including org.springframework.security.oauth:spring-security-oauth2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.security.oauth:spring-security-oauth2 Maven | From 1.0.0 to 1.0.5 | None |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 1.0.0 to 1.0.5 | None |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.0.0 | 2.0.15 |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.0.0 | 2.0.15 |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.1.0 | 2.1.2 |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.1.0 | 2.1.2 |
4 more packages
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.2.0 | 2.2.2 |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.2.0 | 2.2.2 |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.3.0 | 2.3.3 |
org.springframework.security.oauth:spring-security-oauth2 Maven | From 2.3.0 | 2.3.3 |
Products include Pivotal Software Spring Security Oauth.
How do I fix CVE-2018-1260?
Upgrade org.springframework.security.oauth:spring-security-oauth2 to a fixed version for your release line: 2.0.15, 2.1.2, 2.2.2 or 2.3.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2018-1260 being exploited?
There is no known exploitation of CVE-2018-1260 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Pivotal Spring Security OAuth
Sources
Also known as GHSA-rrpm-pj7p-7j9q.