{"answers":{"affected":"2 open source packages ship an affected version, including github.com/docker/docker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-12608 in the wild and no public exploit code.","fix":"Upgrade github.com/docker/docker to 17.06.0-ce or later.","what":"CVE-2018-12608 is a high-severity authentication bypass vulnerability in n/a, published on 10 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-12608 and fix it if it is affected.\n\nWhat it is: CVE-2018-12608 is a high-severity authentication bypass vulnerability in n/a, published on 10 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-12608 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/docker/docker (Go): affected all versions; fixed in 17.06.0-ce\n- github.com/docker/docker (Go): affected all versions; fixed in 17.06.0-ce\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-12608/ (Markdown: https://insights.sbomify.com/CVE-2018-12608/index.md)","id":"CVE-2018-12608","markdown":"https://insights.sbomify.com/CVE-2018-12608/index.md","name":"CVE-2018-12608","record":{"aliases":["DEBIAN-CVE-2018-12608","GHSA-qrqr-3x5j-2xw9","UBUNTU-CVE-2018-12608"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Docker Engine","requires_auth":"none","summary":"Docker Engine incorrectly validated client TLS certificates against system roots, allowing unauthorized clients to authenticate.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moby","vendor":"mobyproject"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"An issue was discovered in Docker Moby before 17.06.0. The Docker engine validated a client TLS certificate using both the configured client CA root certificate and all system roots on non-Windows systems. This allowed a client with any domain validated certificate signed by a system-trusted root CA (as opposed to one signed by the configured CA root certificate) to authenticate.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Docker Authentication Bypass","id":"CVE-2018-12608","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2018-12609"},"packages":[{"ecosystem":"Go","fixed":["17.06.0-ce"],"introduced":["0"],"last_affected":[],"package":"github.com/docker/docker","purl":null,"source":"GHSA-qrqr-3x5j-2xw9"},{"ecosystem":"Go","fixed":["17.06.0-ce"],"introduced":["0"],"last_affected":[],"package":"github.com/docker/docker","purl":"pkg:golang/github.com/docker/docker","source":"GHSA-qrqr-3x5j-2xw9"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-12607"},"products":["n/a"],"published":"2018-09-10","related":[{"cvss_score":8.1,"headline":"Moby Race Condition vulnerability","id":"CVE-2024-36623","kev_date_added":null,"published":"2024-11-29"},{"cvss_score":7.5,"headline":"moby/moby's dockerd daemon encrypted overlay network may be unauthenticated","id":"CVE-2023-28840","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":6.9,"headline":"Moby classic builder cache poisoning","id":"CVE-2024-24557","kev_date_added":null,"published":"2024-02-01"},{"cvss_score":6.8,"headline":"moby/moby's dockerd daemon encrypted overlay network traffic may be unencrypted","id":"CVE-2023-28841","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":6.8,"headline":"moby/moby's dockerd daemon encrypted overlay network with a single endpoint is unauthenticated","id":"CVE-2023-28842","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":6.5,"headline":"NULL Pointer Dereference on moby image history","id":"CVE-2024-36620","kev_date_added":null,"published":"2024-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Docker Engine incorrectly validated client TLS certificates against system roots, allowing unauthorized clients to authenticate.","url":"https://insights.sbomify.com/CVE-2018-12608/"}